[Nut-upsuser] CyberPower UPS Help

Charles Lepple clepple at gmail.com
Thu Feb 16 13:48:23 UTC 2012

On Feb 16, 2012, at 8:34 AM, McCann, Brian wrote:

> Thanks Charles.  I tried something similar on FreeBSD 6.2, but it didn't really help.  I just disabled uhci altogether.  It then gave me access to the ugen devices, but it still didn't detect it.  So I put that aside and tried FreeBSD 8.1 (most of my servers are one or the other) since it's USB support is very different.  In fact, when the port compiled it didn't even use libusb.  I didn't have to turn off uhci, but I did have to fiddle with more permissions then that HowTo said.  I got it working, but I changed so much I'm not sure exactly WHAT did it.  I'm going to start again with a fresh system and I'll post back with the steps and changes I made to make it work.

Cool, thanks for checking on that. (My FreeBSD box is temporarily out of commission until I rewire some things in the basement.)

While I think you are correct in saying that the NUT port won't pull in the libusb port on FreeBSD 8.1, I think what happened is that FreeBSD 8.x includes libusb in the base system. There is still the problem of making sure the kernel doesn't grab the UPS with the uhid device.

A long time ago, I experimented with converting the tripplite_usb driver to use uhid. It seemed much slower and less reliable, but that was definitely back in the 6.x days.

Charles Lepple
clepple at gmail

More information about the Nut-upsuser mailing list