[Nut-upsuser] CyberPower UPS Help

McCann, Brian bmccann at andmore.com
Thu Feb 16 19:35:49 UTC 2012

> -----Original Message-----
> From: Charles Lepple [mailto:clepple at gmail.com]
> Sent: Thursday, February 16, 2012 8:48 AM
> To: McCann, Brian
> Cc: nut-upsuser at lists.alioth.debian.org
> Subject: Re: [Nut-upsuser] CyberPower UPS Help
> On Feb 16, 2012, at 8:34 AM, McCann, Brian wrote:
> > Thanks Charles.  I tried something similar on FreeBSD 6.2, but it
> didn't really help.  I just disabled uhci altogether.  It then gave me
> access to the ugen devices, but it still didn't detect it.  So I put
> that aside and tried FreeBSD 8.1 (most of my servers are one or the
> other) since it's USB support is very different.  In fact, when the port
> compiled it didn't even use libusb.  I didn't have to turn off uhci, but
> I did have to fiddle with more permissions then that HowTo said.  I got
> it working, but I changed so much I'm not sure exactly WHAT did it.  I'm
> going to start again with a fresh system and I'll post back with the
> steps and changes I made to make it work.
> Cool, thanks for checking on that. (My FreeBSD box is temporarily out of
> commission until I rewire some things in the basement.)
> While I think you are correct in saying that the NUT port won't pull in
> the libusb port on FreeBSD 8.1, I think what happened is that FreeBSD
> 8.x includes libusb in the base system. There is still the problem of
> making sure the kernel doesn't grab the UPS with the uhid device.
> A long time ago, I experimented with converting the tripplite_usb driver
> to use uhid. It seemed much slower and less reliable, but that was
> definitely back in the 6.x days.
> --
> Charles Lepple
> clepple at gmail

So for FreeBSD 8.1, you need permissions on two dev nodes.  You do NOT need to disable uhci.
For this ups (usbconfig shows this):

ugen1.2: <UPS OR700 CPS> at usbus1, cfg=0 md=HOST spd=LOW (1.5Mbps) pwr=ON

Here's my /etc/devfs.rules file:

add path 'ugen1.2' group wheel user nut mode 0660
add path 'usb/1.2.0' group wheel user nut mode 0660

You need the second line because the first is only a symlink to the second.

Once I do a bunch more testing of this UPS, I'll email the dev list and have them add it as a "confirmed working" device.


More information about the Nut-upsuser mailing list