[Nut-upsuser] APC SmartUPS 3000VA LCD not connecting

Arnaud Quette aquette.dev at gmail.com
Mon Feb 27 11:38:36 UTC 2012

2012/2/21 Zach La Celle <lacelle at roboticresearch.com>:
> On 02/13/2012 11:41 AM, Arnaud Quette wrote:
>> 2012/2/13 Zach La Celle <lacelle at roboticresearch.com>:
>>> On 02/07/2012 10:58 AM, Zach La Celle wrote:
>>>> On 02/07/2012 10:41 AM, Arnaud Quette wrote:
>>>>> that's what I was suspecting.
>>>>> I've never seen that one before, though!
>>>>> a driver debug output, Ie:
>>>>> $ /lib/nut/usbhid-ups -DDDDD -a rack1ups
>>>>> please, compress the result or sent in a reference to the file.
>>>>> I would also be interested in a 2nd run, calling "export USB_DEBUG=3",
>>>>> before starting usbhid-ups.
>>>>> we should get some visibility from libusb.
>>>>> cheers,
>>>>> Arnaud
>>>> I've put up two files: one without USB_DEBUG=3, and one with USB_DEBUG=3.
>>>> Without:
>>>> http://db.tt/55mUqzJA
>>>> With:
>>>> http://db.tt/Rcf2Phv6
>>>> I hope this helps!
>>>> -Zach
>>>> _______________________________________________
>>>> Nut-upsuser mailing list
>>>> Nut-upsuser at lists.alioth.debian.org
>>>> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/nut-upsuser
>>> I'm back in the office, and can collect more information for you if it
>>> will help.  Is there anything else you need?
>> quite frankly, I still have no clue on what could be happening.
>> have you tried on another USB port?
>> is there anything else cabled on the same USB bus?
>> would you be able to test this device on another system, with different OS?
>> cheers,
>> Arnaud
> I figured out the cause of this problem: incorrect permissions on the
> USB device.  At least, this seemed to fix the problem I had when I
> manually tried to run upsdrvctl and got a permission denied.  The other
> problems may have been solved simply by reinstalling nut, not sure.
> It no longer returns the temperature, line frequency, or load
> percentage, but this is fine for now.
> In case anybody needs to fix their permissions in Debian-based system,
> run lsusb to get your vendorId, productId, and usb bus address, then
> check /dev/bus/usb/<bus number>/<device number> to see its permissions.
>  Mine were 664: changing them to 666 worked for me.  To give an example
> of my udev rule in /etc/udev/rules.d/90-APCUps.rules:
> # APC USB device
> SUBSYSTEM=="usb", ATTR{idVendor}=="051d", ATTR{idProduct}="0003",
> MODE="0666"

this (udev support) is automatically included in for version that
supports the device (generated automatically).
Ie, in your case, as of nut 2.6.0.

> Hope this helps.  Still not sure what was happening at first.  Also, if
> there's any ways to get upsc to read more values from the UPS, let me know.

can you please post an output of "/path/to/usbhid-ups -D -a ..."
just to see if there is more data to retrieve.

Linux / Unix Expert R&D - Eaton - http://powerquality.eaton.com
Network UPS Tools (NUT) Project Leader - http://www.networkupstools.org/
Debian Developer - http://www.debian.org
Free Software Developer - http://arnaud.quette.free.fr/

More information about the Nut-upsuser mailing list