[Nut-upsuser] Debian Squeeze / Powerware 9135 450KVA UPS

Gregory Skelton gregory.skelton at gmail.com
Thu Jan 12 20:38:31 UTC 2012

Hi All,

I'm a system administrator of a large data center, and I've recently
replaced the machine that acted as the nut master for our
cluster/cloud. The machine that was interfacing with our Powerware
9135 450KVA 3 phase UPS, not to confused with Eaton's Powerware 9135,
and was a Fedora Core 4 box running nut version 2.0.3-4 connected by a
serial cable.

We are using these versions of nut on our FC4 machine:
Network UPS Tools - UPS driver controller 2.1.0
Network UPS Tools - BCMXCP UPS driver 0.11 (2.1.0)

We've had intermittent UPS driver problem, but it worked. Now I'm
trying to connect to our UPS using this new machine and I get this:

root at omen:/etc/nut# upsdrvctl start
Network UPS Tools - UPS driver controller 2.4.3
Network UPS Tools - BCMXCP UPS driver 0.23 (2.4.3)
RS-232 communication subdriver 0.17
Connected to UPS on /dev/ttyS0 with baudrate 9600
Communications with UPS lost: Error executing command
Could not communicate with the ups
Driver failed to start (exit status=1)

I've tried to google for an answer and found a great reference, but I
haven't been able to communicate with the UPS

Is there any diagnostics or log files I can create to track down this
problem? "Driver failed to start (exit status=1)" isn't all that

Thanks in advance for any and all help.


PS I have both machines, so if I missed anything I can get it for you.

More information about the Nut-upsuser mailing list