[Nut-upsuser] PowerWalker VFI 3000RT LCD: Device or resource busy

Charles Lepple clepple at gmail.com
Wed Mar 12 03:22:07 UTC 2014

On Mar 6, 2014, at 5:09 AM, Tapio Korkki wrote:

> After this it checks all USB devices until founds the UPS again but from device 002/063 and this goes on and on..

This part is going to be hard to fix. While it may be indirectly caused by NUT, the UPS shouldn't completely disconnect from the USB bus in case of a protocol error (there are many softer ways for it to fail while keeping the connection).

It doesn't sound like it is the USB cable, but if you have another handy, it can't hurt to try.

> I believe this is not permission problem since it gets some reasonable information from the UPS. I have also tried to setup device permissions to 666:
> /lib/udev/rules.d/62-nut-usbups.rules
> --- clip ---
> #  Phoenixtec Innova RT  - blazer_usb
> ATTR{idVendor}=="06da", ATTR{idProduct}=="0005", MODE="666", GROUP="dialout"
> --- clip ---

That looks correct.

> Device /dev/bus/usb/002/062 permissions were: 
> crw-rw-rw- 1 root dialout
> Didn't help. I don't know why the groupname is dialout, it is the same with all rules (nut from RPM package). And yes, nut belongs to dialout group:
> /etc/group
> --- clip ---
> dialout:x:18:nut
> --- clip ---

NUT can only be configured to run as one user/group for all drivers, so the dialout group was picked since the serial ports are usually set to that group.

> I have also tried blazer_usb with every protocol: megatec, megatec/old, zinto

What software does the manufacturer recommend for Windows systems?

Charles Lepple
clepple at gmail

More information about the Nut-upsuser mailing list