[Nut-upsuser] Unable to set up a "serial-over-USB" UPS (APC BZ2200BI-BR)

Douglas A. Augusto daaugusto at gmail.com
Thu Mar 20 14:01:45 UTC 2014

Dear NUT users/developers,

I'm having trouble while trying to configure the UPS APC BZ2200BI-BR[1] in NUT,
which despite having a USB cable it apparently communicates using the serial

The relevant output of 'lsusb' is:

   Bus 002 Device 004: ID 051d:c812 American Power Conversion

The device is registered as /dev/ttyACM0 and uses the kernel module 'cdc_acm'
(USB Abstract Control Model driver).

I've tried most of the listed APC compatible drivers [2] and they all failed.
I'm using NUT version 2.7.1. For instance, using 'usbhid-ups':

   # /lib/nut/usbhid-ups -a apc -u root -x vendorid=051d -x productid=c812 -D
   Network UPS Tools - Generic HID driver 0.38 (2.7.1)
   USB communication driver 0.32
      0.000000 debug level is '1'
      0.000320 upsdrv_initups...
      2.011341 No matching HID UPS found

And 'apcsmart':

   # /lib/nut/apcsmart -a apc -u root -D
   Network UPS Tools - APC Smart protocol driver 3.1 (2.7.1)
   APC command table version 3.1
      0.000000 debug level is '1'
     12.432541 unable to detect an APC Smart protocol UPS on port /dev/ttyACM0
   check the cabling, port name or model name and try again

Moreover, as suggested in [3], I tried without success to force the 'usbserial'
module to load the device as a USB device and hopefully register it as /dev/ttyUSBx:

   # modprobe usbserial vendor=0x051d product=0xc812

I couldn't be able to set up the UPS under apcupsd as well.

Any ideas?

1. http://www.apc.com/products/resource/include/techspec_index.cfm?base_sku=BZ2200BI-BR
2. http://www.networkupstools.org/stable-hcl.html
3. http://lists.alioth.debian.org/pipermail/nut-upsuser/2006-November/001780.html

Thank you,

Douglas A. Augusto

More information about the Nut-upsuser mailing list