[Nut-upsuser] Error message constantly in log

Charles Lepple clepple at gmail.com
Tue May 6 02:51:01 UTC 2014

On Apr 26, 2014, at 4:43 PM, Everett Tsang wrote:

> I'm using Nas4Free, and I'm getting the following message all the time in the Daemon log:
> usbhid-ups[42466]:  libusb_get_report: Unknown Error

That pretty much sums up the USB error handling in *BSD...
> I'm running Nas4Free Shigawire
> Driver usbhid-ups
> Nut Version is 2.7.1
> Internal verion 0.38
That said, there are some options in usbhid-ups to adjust the polling process.

> I tried to get the more detailed error dump, but as I'm a total noob with Nas4Free/FreeBSD, the instructions didn't make a lot of sense to me.  I tried looking for the driver to run the command, but I wasn't sure of the location in Nas4Free structure.  I'm using an embedded install so if someone more familiar with this, can tell me what to run, to get a more detailed report, I'd be more than happy to do it.

You can probably see the path to the driver if you run "ps auxww | grep usbhid-ups". If not, you might ask the Nas4Free folks to document their configuration settings that they use to build NUT.

Charles Lepple
clepple at gmail

More information about the Nut-upsuser mailing list