[Nut-upsuser] access to upsrw

Gene Heskett gheskett at wdtv.com
Tue Dec 29 20:27:22 UTC 2015

Greetings Charles;

I hope you had a nice Christmas, and will have a happy and prosperous new 
year in 2016.

You mentioned upsrw in a message earlier, so I ran it, and found the 
shutdown timeout was only 20 seconds.

gene at coyote:~$ upsrw myups
High voltage transfer point (V)
Value: 140

Low voltage transfer point (V)
Value: 88

Interval to wait after shutdown with delay command (seconds)
Value: 20

Interval to wait before (re)starting the load (seconds)
Value: 30

That 20 seconds is insufficient to allow a gracefull shutdown on this 
system as it seems to need 40 or more seconds to begin a reboot by 
entering the BIOS post routine.

So I tried to reset that to 120 seconds, which the battery can do nicely, 
and I have a 20kw in the back yard that is up and running, lights back 
on in 16 or 17 seconds, so is 98% moot, but found I cannot, even as 
root, adjust this.

gene at coyote:~$ upsrw -s ups.delay.shutdown=120 myups
Username (gene): gene
Password: my user pw here
Unexpected response from upsd: ERR ACCESS-DENIED

Nut was never given a pw on this system. I, and ups however are members 
of group nut, and that has always seemed sufficient until now.

Obviously I don't have something adequately configured, the question of 
course is what?


Cheers, Gene Heskett
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Genes Web page <http://geneslinuxbox.net:6309/gene>

More information about the Nut-upsuser mailing list