[Nut-upsuser] Fwd: SSL only working in DEBUG mode

Charles Lepple clepple at gmail.com
Mon Mar 2 01:39:47 UTC 2015

On Sun, Mar 1, 2015 at 8:10 PM, Melkor Lord <melkor.lord at gmail.com> wrote:
> What puzzles me is the difference
> in behaviour between debug mode and non-debug mode. What could possibly
> happen after upsd detaches itself from the calling shell that make upsd fail
> to handle SSL stuff while working flawlessly without detaching?

I'm thinking it's something here:


> I thought start-stop-daemon was involved because it closes stdin/stdout file
> descriptors after exec()'ing the daemon. I tried "--no-close" option to no
> avail. After that, I validated the init script working fine with
> UPSD_OPTIONS="-D" in /etc/nut/nut.conf.

Not strictly the same as closing the file descriptors, but I tried the

  /sbin/upsd -D >/dev/null 2>&1 < /dev/null

And it still worked. So I need to recompile with debugging symbols -
the Ubuntu packages did not have them.

- Charles Lepple

More information about the Nut-upsuser mailing list