[Nut-upsuser] I/O errors with usbhid-ups and Tripp Lite SMART1500LCDT

Null null at wuffleton.com
Fri Oct 23 06:03:03 UTC 2015

Hi List,

I recently picked up a Tripp Lite SMART1500LCDT while they were on sale 
to pair with my home server, and have tried getting it set up with NUT, 
since it seems to be supported. I can get the whole NUT stack up and 
running, but the driver seems to only stay up for a couple minutes 
before crashing out.

I've uploaded the level 6 debug output of the driver (with my serial 
number removed) here: 

 From what I can gather - it runs into an I/O error, and when it tries 
to reconnect it's unable to claim the device because it's still busy. 
Are there any settings I can set in ups.conf to workaround this or any 
places I should start looking for issues in my configuration? This 
doesn't seem to be a permissions thing, since I'm seeing the same issue 
if I run usbhid-ups as root. I've also explicitly given the 'ups' user 
that I'm running NUT as permissions to the UPS device via udev.

Environment for reference:
NUT Version: v2.7.3.r128.g96c93fb (GIT); v2.7.3 stable exhibits the same 
OS: Arch Linux x86_64
Kernel Version:

Would really love to get this working, and any help would be greatly 

More information about the Nut-upsuser mailing list