[Nut-upsuser] APC Back-UPS BX1400U

Charles Lepple clepple at gmail.com
Sat Feb 20 19:35:02 UTC 2016

On Feb 20, 2016, at 1:08 PM, Charles Lepple <clepple at gmail.com> wrote:
> On Feb 16, 2016, at 12:57 AM, T. Ermlich <pelegrine at gmail.com> wrote:
>> Sorry for the email only send to you, Charles!
>> Here's the one for the list.
> I realize it is no longer a common list configuration. Feel free to use "Reply All" in Gmail - I won't get two copies.
>> torsten at raspberrypi ~ $ uname -a
>> Linux raspberrypi 4.1.13-v7+ #826 SMP PREEMPT Fri Nov 13 20:19:03 GMT 2015 armv7l GNU/Linux
>> torsten at raspberrypi ~ $
> Hmm, I upgraded the base install to kernel 4.1.17+ (mine is armv6l - Model B) and tried usbhid-ups with a CyberPower USB UPS. No issues retrieving the Manufacturer, Product and Serial Number strings. I will see if I can try with an APC later.
> I don't know if we have ruled out permission problems yet. I had the UPS plugged in when I installed the NUT .debs, and it did not change permissions on the /dev/bus/usb/ node for the UPS. I ran "udevadm trigger --subsystem-match=usb --action=change" and it fixed that issue. (Rebooting after installing the package would also work.)

The same combination of NUT (2.7.2) and the kernel on the Pi was able to get the USB strings from an older APC ups as well.

Charles Lepple
clepple at gmail

More information about the Nut-upsuser mailing list