[Nut-upsuser] TrippLite SMART1500LCD no delay before ups shutdown.

Whiteshell Tech neil at whiteshell-tech.com
Tue Aug 22 03:17:55 UTC 2017

> That is going to be hard to diagnose without the usbhid-ups logs for the time when those commands are sent - can you try to keep the log going while sending them, then note the time when the command was sent? You can use the "tee" command:
> /lib/nut/usbhid-ups -DD -a TrippLiteUPS 2>&1 | tee /tmp/log.shutdown.return.txt
> (please use gzip before attaching the log - the mailing list does not accept messages over 40kB without manual intervention.)

Sorry, I think there was a mistake on my part and for the large messages :)

When I originally tried to run "/lib/nut/usbhid-ups -DD -a TrippLiteUPS" 
It complained about other drivers running and did not show any logging 
of commands given to the driver. So I have been now stopping nut-driver 
before running that command. After starting the logging then running 
both upsrw and upscmd I would ctl+c the logging leaving no driver 
running. I now realize that only a little while after canceling the 
logging is when NUT decided to shut down the server.If I leave the 
logging going it does not shutdown.

I am assuming that is supposed to do that when no driver is seen running 
for awhile just incase?? And in that case is not part of my original no 
delay issue?

I have run it again and it looks like ups.shutdown.delay changes show in 
the log @ 28.068836. But no mention at all in the log of shutdown.return 
run @ 80.951272. Just the same "ERR CMD-NOT-SUPPORTED" when attempting 
to run it.

> I think the load.off.delay behavior is expected, but I really thought the others should honor the delay variables. Will have to look further.
> log trimmed; appears to be the same as before?

Yes looks about the same. Also I did a test on new installs of debian 8 
and debian 9. Both worked as expected except for the delay variables are 
still being ignored and "ERR CMD-NOT-SUPPORTED" when running "upscmd 
TrippLiteUPS at localhost shutdown.return".

NOTE: The issue of having to add a systemd service in my first post 
seems to be a proxmox issue, so I will look into that issue else where.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: log.shutdown.return.txt.gz
Type: application/gzip
Size: 5020 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20170821/79cc0155/attachment-0001.bin>

More information about the Nut-upsuser mailing list