[Nut-upsuser] NUT configuration complicated by Stonith/Fencing cabling

Charles Lepple clepple at gmail.com
Mon Feb 13 14:39:04 UTC 2017

On Feb 13, 2017, at 8:08 AM, Tim Richards <tims_tank at hotmail.com> wrote:
> Feb 13 23:11:42 systemd[1] Starting LSB: UPS monitoring software (deprecated, remote/local)...
> Feb 13 23:11:43 usbhid-ups[2093] Startup successful
> Feb 13 23:11:43 upsd[1 932] Starting NUT UPS drivers ..done
> Feb 13 23:11:43 upsd[21 04] not listening on port 3.493
> Feb 13 23:11:43 upsd[21 04] listening on ::1 port 3493
> Feb 13 23:11:43 upsd[2104] listening on port 3493
> Feb 1323:11:43 upsd[21041 no listening interface available

It looks like you have a "LISTEN" line in upsd.conf (in addition to the ones for the IPv4/IPv6 loopback addresses). This worked fine back when the init system actually finished bringing up all of the network interfaces before attempting to start NUT. However, it seems that when moving to systemd, many distributions are depending on some generic multi-user target, rather than the completion of the networking setup. The log message "not listening on" indicates that upsd tried and failed to bind to that listening address.

I made a note to document this: https://github.com/networkupstools/nut/issues/393

I don't have a scratch system running systemd, so I don't have any recommendations on adjusting the dependencies (to wait until networking is really up). There have been some related discussions on other GitHub issues and pull requests: https://github.com/networkupstools/nut/labels/systemd

Another option might be to use "LISTEN" and adjust the firewall rules to only allow packets destined for that interface. (One would hope that the firewall startup script is robust enough to handle this, but again, this is going to be highly dependent on the init system and its configuration.)

Hopefully this gets you further in the startup process.

More information about the Nut-upsuser mailing list