[Nut-upsuser] Device not supported?

Jim Klimov jimklimov at cos.ru
Tue Jul 11 12:30:58 UTC 2017

On July 5, 2017 11:19:55 PM GMT+02:00, Ambrogio Coletti <ambrojohn at gmail.com> wrote:
>I've eventually installed Manuel's packages (nut and nut-client).
>When I run the driver as root (for my tripplite ups) I get:
>/usr/sbin/upsdrvctl start
>Network UPS Tools - Generic HID driver 0.42
>USB communication driver (libusb 0.1) 0.33
>writepid: fopen /var/run/nut/usbhid-ups-trippliteups.pid: Permission
>Can't claim USB device [09ae:1330]: could not detach kernel driver from
>interface 0: Operation not permitted
>Driver failed to start (exit status=1)
>And I had to create manually /var/run/nut.
>What is the problem there?
>On Fri, Jun 23, 2017 at 8:27 PM Manuel Wolfshant
><wolfy at nobugconsulting.ro>
>> On 06/24/2017 04:52 AM, Charles Lepple wrote:
>> > On Jun 23, 2017, at 5:50 PM, Ambrogio Coletti <ambrojohn at gmail.com>
>> wrote:
>> >> "This TrippLite device (09ae:1330) is not (or perhaps not yet)
>> supported by usbhid-ups. [...]"
>> >> but my device (SU2200RTXLCD2U) is supported, as clearly state
>> > No, the HCL also mentions "protocol 4001". For Tripp-Lite, a USB
>> other than 0001 is generally the protocol number. So your SU2200*
>model is
>> different.
>> >
>> > https://github.com/networkupstools/nut/issues/64
>> >
>> >> Then I thought I needed the last src code (2.7.4), hence I built
>it for
>> my machine, but when I run it by:
>> >> /usr/local/ups/sbin/upsdrvctl start
>> > The Protocol 1330 support was added after 2.7.4 was released. You
>> be able to use a 2.7.4 tarball with "productid = 1330" in ups.conf,
>> voltages might be off by a factor of 10. You will also need to adjust
>> udev files manually to fix /dev/bus/usb permissions.
>> >
>> > If you do choose to build using the latest source code from Git, be
>> aware that you will need more tools, as specified in the Developer
>> >
>> > It may be easier to use the 2.7.4 tarball, and add the patch which
>> introduces Protocol 1330 support to the RPM spec file:
>> I've uploaded to http://wolfy.fedorapeople.org/nut a new set of
>> based on the latest source code from git. Unfortunately they do not
>> include any man pages, I did not have time to find a workaround for
>> hard requirement of newer versions for the tools used by the build
>> process to create the man pages. I will fix that in a later set of
>> packages.
>> _______________________________________________
>> Nut-upsuser mailing list
>> Nut-upsuser at lists.alioth.debian.org
>> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/nut-upsuser

Hi all,

I may be a bit late to the main party, but:

* /var/run/nut : on systems with volatile (/var)/run backed by tmpfs, ramdisk etc. - the directory must be created upon every startup with proper owner and rights. Usually init-scripts handle that; systemd-tmpfiles can too (if given an appropriate config file) on newer Linuxes.

* for devfs nodes like sockets of USB stuff, you also need to assign access rights - as done by udev in newer posts to the thread.

Hope this clarifies a bit,

Typos courtesy of K-9 Mail on my Redmi Android

More information about the Nut-upsuser mailing list