[Nut-upsuser] Device not supported?

Manuel Wolfshant wolfy at nobugconsulting.ro
Wed Jul 5 21:35:04 UTC 2017

On 07/06/2017 12:19 AM, Ambrogio Coletti wrote:
> I've eventually installed Manuel's packages (nut and nut-client).
> When I run the driver as root (for my tripplite ups) I get:
> /usr/sbin/upsdrvctl start
> Network UPS Tools - Generic HID driver 0.42 (v2.7.4-418-gb1314c62.7.4.1)
> USB communication driver (libusb 0.1) 0.33
> writepid: fopen /var/run/nut/usbhid-ups-trippliteups.pid: Permission 
> denied
that is odd because nut-client should have created /var/run/nut/. If you 
run rpm -ql nut-client you will notice that /var/run/nut is listed in 
the very last line:

[root at belgrade ~]# rpm -ql --qf "%{name}-%{version}-%{release}\n\n" 
nut-client-2.7.5-0.20170613gitb1314c6.el6.wolfy.usb01 (ignore the 
"usb01" tag, I added it for my personal reference since I built against 
various libusb versions)

/var/run/nut  <=============

> Can't claim USB device [09ae:1330]: could not detach kernel driver 
> from interface 0: Operation not permitted
That's the error I get with one of my UPSes ( an Eaton ) as well. No 
solution so far for me.

> Driver failed to start (exit status=1)
> And I had to create manually /var/run/nut.
> What is the problem there?
I am really puzzled. Do you get any selinux related errors ( running 
aureport -ts today -a should list the AVCs if any )?

> On Fri, Jun 23, 2017 at 8:27 PM Manuel Wolfshant 
> <wolfy at nobugconsulting.ro <mailto:wolfy at nobugconsulting.ro>> wrote:
>     On 06/24/2017 04:52 AM, Charles Lepple wrote:
>     > On Jun 23, 2017, at 5:50 PM, Ambrogio Coletti
>     <ambrojohn at gmail.com <mailto:ambrojohn at gmail.com>> wrote:
>     >> "This TrippLite device (09ae:1330) is not (or perhaps not yet)
>     supported by usbhid-ups. [...]"
>     >> but my device (SU2200RTXLCD2U) is supported, as clearly state here.
>     > No, the HCL also mentions "protocol 4001". For Tripp-Lite, a USB
>     PID other than 0001 is generally the protocol number. So your
>     SU2200* model is different.
>     >
>     > https://github.com/networkupstools/nut/issues/64
>     >
>     >> Then I thought I needed the last src code (2.7.4), hence I
>     built it for my machine, but when I run it by:
>     >> /usr/local/ups/sbin/upsdrvctl start
>     > The Protocol 1330 support was added after 2.7.4 was released.
>     You might be able to use a 2.7.4 tarball with "productid = 1330"
>     in ups.conf, but voltages might be off by a factor of 10. You will
>     also need to adjust the udev files manually to fix /dev/bus/usb
>     permissions.
>     >
>     > If you do choose to build using the latest source code from Git,
>     be aware that you will need more tools, as specified in the
>     Developer Guide:
>     http://networkupstools.org/docs/developer-guide.chunked/ar01s03.html#building
>     >
>     > It may be easier to use the 2.7.4 tarball, and add the patch
>     which introduces Protocol 1330 support to the RPM spec file:
>     https://github.com/networkupstools/nut/commit/4eff5b7068e9873ce11b5a296f403e8cdf0e3580
>     I've uploaded to http://wolfy.fedorapeople.org/nut a new set of
>     packages
>     based on the latest source code from git. Unfortunately they do not
>     include any man pages, I did not have time to find a workaround
>     for the
>     hard requirement of newer versions for the tools used by the build
>     process to create the man pages. I will fix that in a later set of
>     packages.
>     _______________________________________________
>     Nut-upsuser mailing list
>     Nut-upsuser at lists.alioth.debian.org
>     <mailto:Nut-upsuser at lists.alioth.debian.org>
>     http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/nut-upsuser

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20170706/cfceb6f3/attachment-0001.html>

More information about the Nut-upsuser mailing list