[Nut-upsuser] Cyberpower PR2200ELCDRT2U

Charles Lepple clepple at gmail.com
Fri Nov 10 13:59:41 UTC 2017

[please use reply-all to include the list. thanks!]

> On Nov 9, 2017, at 9:19 PM, Christoph Lampl <chris at weeone.de> wrote:
> Hey guys, :)
> recently, I installed Cyberpower PR2200ELCDRT2U, however, I have not managed to get this UPS working with FreeNAS 11, yet.
> According to compatibility list, PR2200 should work fine, when using powerpanel driver:
> http://networkupstools.org/ddl/Cyber_Power_Systems/
> http://networkupstools.org/ddl/Cyber_Power_Systems/PR2200.html

Looking at the PR6000LCD... entry, it looks like PR*LCD models might be different than the older PR* ones.

What do you get from "sudo usbconfig dump_device_desc"? (You can trim any non-UPS data - I'm mostly interested in idVendor and idProduct. Also, if you don't want to share the full serial number, it would be good to know how many characters there are.)

I suspect this UPS will work with the usbhid-ups driver, or if not, it can be made to work with minor NUT configuration changes. I forget how you choose a "generic" USB connection in FreeNAS - maybe someone else can chime in on that point?

> However, when trying to establish a connection between battery and FreeNAS Server, either using usb cable or serial cable, I receive the same error messages in the console of FreeNAS:
> Nov 10 03:01:37 storageunit root: /usr/local/etc/rc.d/nut: WARNING: failed precmd routine for nut

^ This command probably indicates that the NUT driver failed to start, so the NUT upsd process probably will not start, either.

> Nov 10 03:01:37 storageunit upsmon[8817]: UPS [PR2200ELCDRT2U]: connect failed: Connection failure: Connection refused
> Nov 10 03:01:37 storageunit upsmon[8817]: Communications with UPS PR2200ELCDRT2U lost

^ upsmon "Connection refused" errors (on FreeNAS, or other connections to localhost) are usually a consequence of upsd not starting, so this should resolve itself once you can get the driver running.

> I tried connecting to PR2200 using a Laptop with preinstalled Cyberpower Personal Edition. Everything is working fine at this point and the software displays battery details correctly! However, as soon as I try to establish a connection between FreeNAS and Cyberpower PR2200, I receive these error messages. I spent many hours in reconfiguring and trying new/different ports, however, it looks like I’m going in the wrong direction, because I can’t get this battery communicating with FreeNAS correctly.

I doubt this will be an issue here, but I would recommend choosing the port you want to ultimately use (serial, USB, network) and making sure that it still works with Cyberpower's software before switching to NUT. Some older UPSes (and likely not even from Cyberpower) did not deal well with switching between ports, and required a power cycle to switch.

> OS Name and Version: FreeNAS 11.0U4, no custom modifications
> Cyberpower PR2200 Firmware: 4.520
> RMCARD205 Firmware: 1.0.9

for reference, I think this version of FreeNAS includes NUT 2.7.4.

If this works with a different driver, would you please send a snapshot of the information you get from upsc, upscmd and upsrw as mentioned here? http://networkupstools.org/stable-hcl.html#footnotes


More information about the Nut-upsuser mailing list