[Nut-upsuser] testing shutdown: pc not restarting; and "ups unavailable" messages

nut.user.u830 at neverbox.com nut.user.u830 at neverbox.com
Thu Feb 1 17:01:54 UTC 2018

> It actually occurred to me that I could try this with another (any other) computer here at work, so I did. I set the BIOS to "always on" after power cut. I booted ubuntu. I did "sudo shutdown -h now" from the console. The pc switched off as expected. Then I removed the power cable and then plugged it back in. According to the theory above, this should have caused the computer to detect a power loss and turn itself back on. Instead it remained off (as I expected).

In light of the last few messages I tried again but this time I kept it off for a few minutes rather than a few seconds before plugging the power cord back in, and this time it did come back on. Wow! (That's still the computer at work, though.)

If it is possible that this is motherboard-dependent I shall have to try again with the media server computer at home that is supposed to be rescued by the UPS. I envisage two cases.

1) if the computer does restart after I switch it off and then pull and (a while later) reinsert the power cord, then it stands a chance of working with the UPS, but I still need to understand why it hasn't worked so far.

2) if the computer stays off, there is little hope that any software configuration of nut will make the ups turn it back on; except perhaps for Lee's suggestion of "turning it off but not quite". On that note, where in the file system should I be looking for the NUT shutdown script please?

More information about the Nut-upsuser mailing list