[Nut-upsuser] Monitor Eaton 93PS UPS

Jim Klimov jimklimov at cos.ru
Tue Feb 12 14:48:24 GMT 2019

On February 12, 2019 9:37:17 AM UTC, nicolae788 <nicolae788 at gmail.com> wrote:
>I also operate an HP T1500 G3 which it's an Eaton made UPS. Connected
>usb i get frequent communication errors and data aquisition stopped.
>has a serial connection, also. Operating via serial has no trouble.
>it's something related to usb setting in bios, i.e. Legacy mode, speed
>setting, etc.
>However on serial mode looks like the eaton or hoe power protector
>does not record any statistics...
>On Tue, 12 Feb 2019, 11:24 <lst_hoe02 at kwsoft.de wrote:
>> Zitat von lst_hoe02 at kwsoft.de:
>> > Hello,
>> >
>> > we try to use Network UPS tools to monitor a network connected
>> > 93PS UPS. It basically works but we get frequent "Data is stale -
>> > check driver" warnings with a "data is no longer stale" shortly
>> > after in the log. We tried both snmp-ups and netxml-ups driver and
>> > both raise the same error. If have captured the communication
>> > between nut and UPS but all request/responses are way below a
>> >
>> > Any idea what is going wrong?
>> >
>> > NUT version used is from Ubuntu 18.04 repository (2.7.4) and Eaton
>> > Management Card is on latest firmware.
>> I found this issue around a year ago but it is related to USB not
>> network in this case. Any idea if there is something similar at the
>> network driver code?
>> https://github.com/networkupstools/nut/issues/542
>> Regards
>> Andreas
>> _______________________________________________
>> Nut-upsuser mailing list
>> Nut-upsuser at alioth-lists.debian.net
>> https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/nut-upsuser

FYI: Just in case it proves to be related, I logged a similarly sounding issue recently as https://github.com/networkupstools/nut/issues/651 (or 661?) - my guess is maybe somewhere a rounding delta got truncated in the maths, causing a quick flop of data stale and unstale verdicts.

Also FYI, I had some connectivity issues with an USB UPS using libusb-0.1 which were resolved by switching to 1.0 or 1.0-0.1-compat. I think the PR for that is still open in upstream NUT, so it is not quite in master - but should be easily applicable (and of course one should build/package it from source).

Hope this helps,
Jim Klimov

Typos courtesy of K-9 Mail on my Android

More information about the Nut-upsuser mailing list