[Nut-upsuser] New User Questions - With Belkin USB

David White whitedavidp at yahoo.com
Mon Jul 15 16:15:04 BST 2019

Hi Charles and thanks for your help.

1. I just re-started the Ubuntu/Android system. This runs a root script 
including "service nut-server start" followed by the same for 
nut-client. I can check the status on both and they show as running. I 
can see expected results running "upsc belkinusb".

2. When I check the results from "netstat -t -n" I am NOT finding 
anything on 3493. Hmmm. I then tried "netstat -l" since there should be 
a server socket listening on 3494, right? There is nothing of 3493. But 
I do see an entry with local address = localhost:nut. When I "cat 
/etc/services" I find nut listed on 3493.

3. So I run "netstat -l | grep nut" and I see the socket and I see an 
entry for what looks like a stream listener tied to 

4. I did not know of the -DD option on upsmon and likely would not have 
thought of this anyhow. In the output I almost immediately see a 
connection failure to belkinusb at localhost for the socket saying 
permission denied. That doesn't look right. But not exactly what that 
means or how to fix it.

This seems to be progress of a sort, at least for my understanding of 
all this. Any further comments/tips?


On 7/14/2019 8:18 PM, Charles Lepple wrote:
> On Jul 12, 2019, at 2:39 PM, David White wrote:
>> Thanks Roger for all your help here. I hope the 2 attachments come through. The .sh is my doctored version of the script and the .report is its output. I welcome any suggestions or ideas about what might be causing my problems with monitoring to the Belkin UPS. Cheers
> Hi David,
> Nothing looks out of order in your configuration files. (They are fairly similar to a configuration I am currently running on Ubuntu 18.04.)
> You mentioned in the other thread that Ubuntu is running in a chroot in Android. There is a chance that the Android kernel configuration is messing with things here, and you may need to use strace to watch some of the system calls.
> In the mean time, what if you stop the nut-client service, and run upsmon in debugging mode?
> sudo /sbin/upsmon -DD
> Also, what do you get from "netstat -tn | grep -w 3493"?

More information about the Nut-upsuser mailing list