[Nut-upsuser] How to shutdown macOS / mac OSX from Network UPS Tools client - NUT

Charles Lepple clepple at gmail.com
Tue Jun 11 04:05:58 BST 2019

On Jun 10, 2019, at 5:50 PM, Joe Gervasio wrote:
> The only thing I can see in the system.log that may be relevant is :-
> Jun 10 22:06:36 Joes-iMac com.apple.xpc.launchd[1] (com.apple.xpc.launchd.domain.system): Session adoption is only allowed in user domains.
> This message occurs at the approximate time the shutdown is requested. No idea what it means, or even if it’s related.
Well, carp. I'm seeing that same message, too. (macOS 10.14.5) It happens when I run upsmon from launchd, and when the shutdown time arrives.

As a short-term solution, you can start upsmon via sudo, and that should work. (I got upsmon to launch shutdown, but I killed it before it finished.) I have not tried logging out after running sudo.

I will poke around and see what other shutdown methods might work from a launchd context.

More information about the Nut-upsuser mailing list