[Nut-upsuser] raspberry pi and tripplite_usb

grumpy at mailfence.com grumpy at mailfence.com
Fri Sep 27 13:36:15 BST 2019

On Tue, 10 Sep 2019, Charles Lepple wrote:

> On Sep 10, 2019, at 10:40 AM, grumpy at mailfence.com wrote:
>> i have a OMNIVS1500XL
>> i have used nut for several years on a full sized pc with no problems
>> i am trying to get nut working with this ups on a raspberry pi
>> i tried with a pi 3b running raspbian stretch
>> i tried with a pi 3b running raspbian buster
> The “unable to handle kernel paging request” points to a kernel driver issue. What if you try the following suggestion?
> https://github.com/raspberrypi/linux/issues/2977#issuecomment-519444888
> A useful bit of information would be the output of “lsusb -v -d 09ae:”
> Another thing to try is one of the libusb-1.0 branches in Git: https://github.com/networkupstools/nut/issues/300
> One of the branches towards the end of the issue should work.
> Some details on rebuilding from Git are here: https://github.com/networkupstools/nut/wiki/Building-NUT-on-Debian,-Raspbian-and-Ubuntu
> You will need the libusb-1.0 header package as well.

well after a few weeks of piddle'n i have a solution
building with libusb-1.0 yielded the same results
system crashes
dwc2 works but restricts usb performance
that was not acceptable for the pi i wanted to connect to
so i set up a raspberry pi zero w with dwc2 just for monitoring the ups
i am guessing this driver is not used enough for the author to update

More information about the Nut-upsuser mailing list