[Nut-upsuser] AVR750U Low Power not Triggering Shutdown

Scott Colby scott at scolby.com
Sun Jun 28 06:39:03 BST 2020

On Sat, Jun 27, 2020, at 23:11, Manuel Wolfshant wrote:
> On 6/28/20 5:54 AM, Scott Colby wrote:
>> I'm not convinced this is the problem; I think that pfSense has
an alternative way of running the NUT components:
# ps aux | grep ups
root    45456   0.0  0.1   6796   884  -  Is   02:22    0:00.01 /usr/local/sbin/upsmon
uucp    45751   0.0  0.1   6796   772  -  S    02:22    0:00.10 /usr/local/sbin/upsmon
uucp    46796   0.0  0.1   6888   888  -  Ss   02:22    0:00.45 /usr/local/libexec/nut/usbhid-ups -a AVR750U
root    56752   0.0  0.1   6788   832  -  Ss   02:22    0:00.13 /usr/local/sbin/upsd -u root
root    39437   0.0  0.2   6828  2464  0  S+   02:46    0:00.01 grep ups

Is there anything else that should be running?
> AFAIK, no, those 3 daemons should do the job. But just for the fun of it, I would test changing that variable anyway. There is nothing to lose, after all.


I changed to MODE=standalone and found some new behavior, see below.


>> Would you expect `upsmon -c fsd` to not work as I described above
(system halting but UPS not power cycling) if MODE was set to none
but upsmon, the driver, and upsd were running?
> If it is running ( i.e. started ) -c fsd should trigger an immediate shutdown. quote from man upsmon:

> *-c* *command*
> Send the command *command* to the existing upsmon process. Valid commands are:

> *fsd*
> shutdown all master UPSes (use with caution)


After rebooting having set MODE=standalone, I found that `upsdrvctl
shutdown` now successfully shuts down the UPS. I changed back to
MODE=none and the same command still works. I'm not sure what's
going on there other than perhaps I wasn't being patient enough on
my earlier attempts. Unfortunately, `upsmon -c fsd` still does not
power off the UPS, no matter how long I wait. It seems like this
used to be an issue earlier (https://forum.netgate.com/post/707181)--maybe
it has come back? I may reach out on the Netgate forums as well.

I also tried `upscmd AVR750U shutdown.return`, which properly shut
down the UPS but did not ever bring it back up. I tried this both
on mains power and on battery. In the latter case, I reconnected
the UPS to the mains and waited 5 minutes. It didn't turn itself
back on.

I'm now becoming suspicious of a couple of the values reported by
- battery.charge.warning = 30, but there is no battery.charge.low.
  Does this mean that the low battery flag will never be raised?
- ups.timer.reboot, ups.timer.shutdown, and ups.timer.start all are
  65535. I know this is FFFF, and so there's a chance that it's just
  the default response for an unsupported variable, but could this
  mean that the UPS will wait 18 hours before turning itself back on?

It's time for me to sleep on this for a bit and come back to
troubleshooting later. Thanks for your help tonight!

More information about the Nut-upsuser mailing list