[Nut-upsuser] exec_cmd(/path/upssched-cmd event) returned 78

Le Chaudron Nautique vanvan at chaudron-nautique.fr
Thu Mar 19 21:30:23 GMT 2020


not sure if it is a scripting problem or an owner/group problem but when 
I try to send an email following en event using upssched-cmd, the script 
exits on the line where I send the email with this message in syslog :

Mar 19 20:49:51 chaudron-nautique upssched[1377]: 
exec_cmd(/path/upssched-cmd onbatt1) returned 78

The log messages prior to the email (logger -t upssched-cmd message) can 
be found in syslog thus I'm sure that upssched-cmd is called when the 
event occurs and if I run ~#./upssched-cmd onbatt1as root, the mail is 
sent properly.

I tried a few things regarding privileges on nut/mail/msmtp but could 
not make it work.

If someone knows what I need to do, I'd be happy !



OS : debian buster (10.3)

Package to send the email : msmtp 1.8.3-1 amd64

Nut : nut/stable 2.7.4-8

Installed under root, via apt install nut

Ups : APC BE700G-FR (ES serie)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/nut-upsuser/attachments/20200319/5ea9fd03/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature4.jpg
Type: image/jpeg
Size: 18000 bytes
Desc: not available
URL: <http://alioth-lists.debian.net/pipermail/nut-upsuser/attachments/20200319/5ea9fd03/attachment-0001.jpg>

More information about the Nut-upsuser mailing list