[Nut-upsuser] USB drivers not found when compiling

Tyler Montney montneytyler at gmail.com
Mon Mar 23 00:50:11 GMT 2020

Came across this in the process of troubleshooting:

My whole reason for compiling from source is to add SSL support (as it
doesn't seem available through the package manager). Apt list shows these

libusb-1.0-0-dev/stable,now 2:1.0.22-2 armhf [installed]
libusb-1.0-0/stable,now 2:1.0.22-2 armhf [installed]
libusb-1.0-doc/stable,now 2:1.0.22-2 all [installed,automatic]

Config.log shows this:

configure:8538: checking for libusb version via pkg-config
configure:8545: checking via libusb-config
configure:8557: result: none found

Tried compiling without USB, fails but now complains it can't find OpenSSL.
Apt list shows this installed:

openssl/testing,now 1.1.1d-0+deb10u2+rpt1 armhf [installed]

Compiling without USB or SSL compiles successfully. I assume NUT requires a
specific version of these libraries, and if so, which versions are the
right ones? Platform is a newly installed distro of latest Raspbian on a
Raspberry Pi 3. When I installed from the package manager, everything
worked great (just missing the SSL support). I've been referring to these

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/nut-upsuser/attachments/20200322/5d0ff288/attachment.html>

More information about the Nut-upsuser mailing list