[Nut-upsuser] Powercool UPS compatibility

Jim Klimov jimklimov at gmail.com
Thu Apr 8 09:38:26 BST 2021

I took a look at https://github.com/dmacias72/NUT-unRAID/ plugin source
(not sure it is the one you have, just the first recent plugin from

Unfortunately it does not seem to reference actual NUT source well, nor a
plugin version, but just hoards several timestamped tarballs with binaries.
By commit comments it seems that at least at some point they used the
"libusb-0.1+1.0" branch which is one of our attempts to handle modern
libusb-1 in NUT (note none of the attempts yet were merged to master or
released "officially", but we are on it).

I can't quickly say if latest plugin builds are based on that too, or if
you may have a mismatch with drivers last built for libusb-0.1 trying to
use libusb-1.0 on the server. APIs differ so such mismatch might cause
crashes, or just fail to start if dynamic linking detects it.

As for ups.conf, I think you should try a minimal config like:


(port probably may refer to /dev/usb/... if that is persistent across boots
and device plugs, but does not have to).

What also comes to mind are issues with linux user privileges - whether
that account which runs NUT may connect to USB device nodes. But if
nut-scanner worked, probably that is okay.

If you can edit /etc/rc.d/rc.ups, in the line which starts upsdrvctl you
can add debugging with -DDDDDD which should show its attempts to find the
USB device and possible griefs it may have along the way.

Note that currently, an enabled debugging mode may preclude backgrounding
of the driver or other NUT daemons so not sure if you'd need to add & to
the end of line so upsdrvctl is backgrounded still.

Or if you have shell access, similarly you can run
  /usr/libexec/nut/nutdrv_atcl_usb -DDDDDD -a powercool

Hope that helps,
Jim Klimov

On Thu, Apr 8, 2021, 07:44 James Billinge <jammybisme at hotmail.com> wrote:

> Hi Jim
> Thanks for the reply.
> In NUT under unRAID there is indeed a setting to enter a driver in.
> Which driver are you suggesting I try as nutdrv_qx makes NUT work, but no
> communication between NUT and the UPS.
> Just tried nutdrv_atcl_usb.c as driver and NUT will not start.
> Is there anything else I need to enter in UPS.conf to get it to work?
> Regards
> James
> Sent from my iPhone
> On 8 Apr 2021, at 02:22, Jim Klimov <jimklimov at gmail.com> wrote:
> I believe nutdrv_atcl_usb is orthogonal to nutdrv_qx "fuji" subdriver.
> They both handle devices using an "ATCL" USB chip which does not have a
> registered vendorId/productId, but that is where similarity stops.
> Different UPS vendors implemented different protocols and abilities using
> that chip as a transport, hence two unrelated drivers.
> It seems the HCL entry appeared in relation to this discussion:
> https://github.com/networkupstools/nut/issues/203
> Looking at
> https://github.com/networkupstools/nut/blob/master/drivers/nutdrv_atcl_usb.c
> it indeed does not have many settings, just an alternate "vendor" string to
> match on a device which it finds with hardcoded vid:pid by looking at all
> USB devices.
> Unfortunately I can't help with setup of unRAID bit. I'd assume there is a
> place to state which NUT driver you want.
> Jim
> On Tue, Apr 6, 2021, 22:12 James Billinge via Nut-upsuser <
> nut-upsuser at alioth-lists.debian.net> wrote:
>> I have spent the last few days researching the possibility of using a
>> Powercool UPS with NUT under unRAID.
>> I have posted my findings on their forums and not had much response
>> besides other users wanting it to work too.
>> https://forums.unraid.net/topic/104685-powercool-ups-compatible/
>> How does one utilise nutdrv_actl_usb?
>> https://networkupstools.org/docs/man/nutdrv_atcl_usb.html
>> As a means of connecting to a Powercool UPS along with nutdrv_qx?
>> Seeing this -
>> https://github.com/cbedgar/nut/blob/1e9216399b890b0770a0e8b158109eaa5e61d332/data/driver.list.in
>> Fills me with hope that it’s feasible.
>> Is it feasible or am I wasting my time?
>> James
>> _______________________________________________
>> Nut-upsuser mailing list
>> Nut-upsuser at alioth-lists.debian.net
>> https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/nut-upsuser
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/nut-upsuser/attachments/20210408/6838f468/attachment.htm>

More information about the Nut-upsuser mailing list