[Nut-upsuser] NOTIFYCMD only works with upsmon -D ( in debug mode )

Jim Klimov jimklimov+nut at gmail.com
Wed Mar 2 13:56:17 GMT 2022

That is odd, I wonder if stdout/stderr get processed differently with debug
on or off, and/or daemon/foregrounding involved.

Is this with a packaged NUT 2.7.4 or with a recent (custom?) build from the
master branch? Last month PRs were merged to separate the debugging in
daemons from deciding to foreground/background their processes (and others
to specify `debug_min` in config files and so not hack `-D` into init
scripts or service units). Default activity should remain the same for the
principle of least surprise, but fallout is possible with any change :)


On Wed, Mar 2, 2022, 11:47 Roger Price <roger at rogerprice.org> wrote:

> On Tue, 1 Mar 2022, Arno de Kok wrote:
> > The NOTIFYCMD only works when I run upsmon -D.
> > If I run upsmon normally then I get NOTIFY message’s:
> > Broadcast message from nut at raspberrypi (somewhere) (Tue Mar  1 20:33:41
> 2022):
> > UPS servers at localhost on battery
> >
> > But only with upsmon -D I also get the ouput from the user defined
> script ( the yellow part is from the user defined script in NOTIFYCMD )
> Nothing yellow for me, but I read my mail with Alpine.
> > Broadcast message from nut at raspberrypi (pts/0) (Tue Mar  1 20:34:43
> 2022):
> > UPS servers at localhost on battery
> > Python, UPS on battery
> > WARNING:root:Python UPS message!
> Is this anomaly repeatable?
> May we see your upsmon.conf? And maybe the Python script if it's not too
> big.
> Roger_______________________________________________
> Nut-upsuser mailing list
> Nut-upsuser at alioth-lists.debian.net
> https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/nut-upsuser
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/nut-upsuser/attachments/20220302/72c58284/attachment.htm>

More information about the Nut-upsuser mailing list