Assertion error?

Philipp Haselwarter philipp.haselwarter at
Mon Dec 13 13:21:04 GMT 2010

Hi Josh,

I ran into the same problem, a few times now.
Moving the message out of the folder, re-running offlineimap and moving
it back in after a while somehow magically worked, so I'd guess the
problem is related to something other than the mail itself.

To track it down, I tried running with IMAP-debug activated the last
time I got a mail that caused the error, but that resulted in a 8MB log
file; I'll attach an excerpt of it. If anyone is interested in looking
at the whole log, I'll send it directly, not over the list (or upload it
somewhere). I hope everyone's okay with .tar.xz?

I'm using offlineimap 6.2.0 with a local dovecot 2.0.8.

Would be great to hear if anyone has an idea of what's going on there!

Philipp Haselwarter

-------------- next part --------------
A non-text attachment was scrubbed...
Name: error-excerpt.log.tar.xz
Type: archive/tar
Size: 72168 bytes
Desc: relevant part of the log
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: bad_mail.tar.xz
Type: archive/tar
Size: 4948 bytes
Desc: the mail that caused the trouble
URL: <>

More information about the OfflineIMAP-project mailing list