Invalid Config with 6.3.1??

Paul Grove paul.a.grove at
Mon Dec 13 14:56:45 GMT 2010

Sorry Sebastian, I missed your email here,

I am not specifying my passwords in the config file, It is exactly as
described, with the exception of the xxxx's over the email addresses and

In jgoerzen's master I am prompted for a password, and It works without
error. (well I'm getting intermittent crashes every 24hr or so, but it is
the reason I am upgrading to see if the newer version fixes this and is 
not as far as I can tell the same error).

I have the config file in ~/.offlinerc and I have both nicolas33's and
jgoerzen's downloaded in my home, I can launch either but only
nicolas33's gives me these errors - and does not ask for password.

Hope this helps,


Excerpts from Sebastian Spaeth's message of Mon Dec 13 14:35:39 +0000 2010:
> On Mon, 13 Dec 2010 10:42:37 +0000, Paul Grove <paul.a.grove at> wrote:
> > WARNING: Error occured attempting to sync account Gmail: 'NoneType' object has no attribute 'replace'
> > Next sync in 1:00
> This is the
> exact reason why I would love to have the -1 not use any threads. Now, we
> can't see in which file or line this exception occurs...
> With your sample config file, I could reproduce the very same error even
> in jgoerzen's master, so I am not sure what the difference is. Inserting
> debug prints I traced my error down to repository.IMAP().getpassword() returning None,
> which leads to the Exception in imaplib's login() function.
> You did not specify any passwords in your offlineimap.rc, did you? How
> do you pass your passwords to offlineimap for those accounts?
> Sebastian

More information about the OfflineIMAP-project mailing list