sslcacertfile: "SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed"

Johannes Kastl mailinglisten at
Tue Aug 9 17:13:38 BST 2011

Hi there,

I havent used my offlineimap setting in a while, today I got:

>  Establishing connection to
>  WARNING: Error occured attempting to sync account YYYY: Traceback (most recent call last):
>   File "/Users/XXXX/bin/offlineimap/offlineimap/", line 191, in syncrunner
>     self.sync(siglistener)
>   File "/Users/XXXX/bin/offlineimap/offlineimap/", line 246, in sync
>     remoterepos.syncfoldersto(localrepos, [statusrepos])
>   File "/Users/XXXX/bin/offlineimap/offlineimap/repository/", line 121, in syncfoldersto
>     srcfolders = src.getfolders()
>   File "/Users/XXXX/bin/offlineimap/offlineimap/repository/", line 242, in getfolders
>     imapobj = self.imapserver.acquireconnection()
>   File "/Users/XXXX/bin/offlineimap/offlineimap/", line 207, in acquireconnection
>     cacertfile = self.sslcacertfile)
>   File "/Users/XXXX/bin/offlineimap/offlineimap/", line 141, in __init__
>     IMAP4_SSL.__init__(self, *args, **kwargs)
>   File "/Users/XXXX/bin/offlineimap/offlineimap/", line 1871, in __init__
>     IMAP4.__init__(self, host, port, debug, debug_file, identifier, timeout)
>   File "/Users/XXXX/bin/offlineimap/offlineimap/", line 309, in __init__
>, port)
>   File "/Users/XXXX/bin/offlineimap/offlineimap/", line 186, in open
>     cert_reqs = requirecert)
>   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/", line 372, in wrap_socket
>     ciphers=ciphers)
>   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/", line 134, in __init__
>     self.do_handshake()
>   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/", line 296, in do_handshake
>     self._sslobj.do_handshake()
> SSLError: [Errno 1] _ssl.c:503: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

I checked out the rc4 and tried, and got another error message:

> Account sync YYYY:
>  ***** Processing account YYYY
>  Copying folder structure from IMAP to MappedIMAP
>  Establishing connection to
>  WARNING: Could not connect via SSL to host '' and non-standard ssl port 993 configured. Make sure you connect to the correct port.
>  ***** Finished processing account YYYY

I do not know why port 993 should no longer work, I haven't changed it.

Deleting the sslcacertfile in the offlineimaprc gets the sync working,
but only without SSL verification. Which worked some time ago.

Any hints?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 259 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the OfflineIMAP-project mailing list