Always the same error: does not have a message with UID

Sebastian Spaeth Sebastian at
Mon Aug 15 09:23:51 BST 2011

On Mon, 15 Aug 2011 07:51:13 +0000, Leon Bogaert <leon at> wrote:

> Copy message 60 from klanten/Hippios:
>  WARNING: ERROR attempting to copy message 60 for account timonline:Traceback (most recent call last):

>   File "/home/leon/src/offlineimap/nicolas33/offlineimap/folder/", line 215, in getmessage
>     raise OfflineImapError(reason, severity)
> OfflineImapError: IMAP server 'timonline-remote' does not have a message with UID '60'
> Always the same UID. So I guess that message is corrupted on the server or something. With the version of OfflineIMAP from the default Ubuntu 11.04 repositories I didn't get this message. 
> I fixed it by removing the raise on line 297 of folder/
> Is this something that could be fixed in the git version?

Well, it would be interesting to see why it thinks there is a message
UID 60 and then fails to retrieve it rather than papering over the error
by ignoring it. In order to investigate further it would be good to get
a debug log of a failing sync. Perhaps you can create one with -d imap
-l debug.log and send me the file (purge passwords from it).

This way we can see what's really happening.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
URL: <>

More information about the OfflineIMAP-project mailing list