IDLE does not idle, offlineimap immediately returns

Franz Fellner alpine.art.de at gmail.com
Thu Jul 25 07:30:16 BST 2013


Hej Tomek,

After some fiddling it seems to work - idling on both accounts :)
It was a typo in "maxsyncaccounts"...
I still had issues with idling on the Web.de-Account - turned out my GMail-mails didn't make it into the INBOX but Spam-folder, and there I don't idle ;)

So thx again for your help! Going to fiddle with notmuch/afew now :)

Franz


On Dienstag, 23. Juli 2013 15:35:54 CEST, Tomasz ┼╗ok wrote:
> Hi Franz,
>
> On 2013-07-23 at 15:17, Franz Fellner wrote:
>>> IDLE working (and benefit the most from it) you should run offlineimap
>>> normally, but set autorefresh to a high value and idlefolders 
>>> to your INBOX.
>> It would be great if this behaviour would be documented 
>> better. I was not aware that I had to use autorefresh, when I 
>> actually want to use IDLE. IDLE setup uses keepalive, so I 
>> thought that should be enough.
>
> Well, I am just sharing my experience, maybe things are not 
> exactly as I say in
> the internals of OfflineIMAP :)
>
> The general and minimal template for my account configuration 
> looks like this:
>
>
> [Account gmail]
> localrepository = GmailLocal
> remoterepository = GmailRemote
> autorefresh = ???
>
> [Repository GmailLocal]
> type = Maildir
> localfolders = ???
>
> [Repository GmailRemote]
> type = Gmail
> remoteuser = ???
> remotepass = ???
> idlefolders = ['INBOX']
>
>
> The "???" parts are what I customize to get it working for 
> different accounts.
> Of course, for "type = IMAP" there is also a "remotehost" config entry.
>
>
>>> Then offlineimap will stay in the background, it will have to 
>>> do a "SO SLOW"
>>> sync from time to time, but IDLE will take care of handling 
>>> you the e-mails
>>> instantly.
>> Those slow syncs don't bother me, if they only occur occasionally.
>> 
>> But now I ran into another issue (which looks like a bug to me):
>> From my two accounts offlineimap only syncs the first one. 
>> After syncing it immediately starts idling on that. The second 
>> one neither get's refreshed nor idled.
>
> Maybe "accounts" or "maxsyncaccounts" are not set properly in the [general]
> config section?
>
> Cheers,
> Tomek
>
>





More information about the OfflineIMAP-project mailing list