how to get Orca speaking at login, and also retriev use of TTY1

Al Sten-Clanton albert.e.sten_clanton at
Mon Dec 18 23:05:58 UTC 2017

Greetings!  I'm pasting below a message I sent to the Blinux list 
yesterday.  I'm not sure if the second question there belongs on this 
list, but the first one surely does and I suspect they're related.

I ran into some problems when I upgraded from jessie to stretch this 
fall.  I'd like to fix these two especially without having to reinstall.

First, when I used jessie, Orca spoke at login time.  Now, it doesn't. I 
guess when to do it, and then I get a message from Orca like "screen 
reader on, 17 pushbutton."  (I guess this last thing is supposed to be a 
"feature," since I also got it on the stretch live CD, but I don't know 
what it's good for.) For this problem, what can I change to get back my 
spoken login prompt?

Second, after I've hit ENTER on this "pushbutton," I can do my usual 
press of the Windows key and run firefox or whatever.  However, if I go 
to another terminal to use speakup, for example, tty1 no longer 
works--or, at least, I have to log in there again.  Typically, tty2 or 
sometimes another one becomes my graphical terminal.  I end up minus a 
terminal.  Does anyone know if this is fixable?

I've tried using Google and the Debian site itself for direction, but so 
far have found nothing.

Also, this is an Intel x86-64 machine, in case it matters.

Thanks for any help, or for pointers to information.


More information about the Pkg-a11y-devel mailing list