Bug#911362: few packages report not able to register with accessibility bus

Samuel Thibault sthibault at debian.org
Wed Aug 28 08:59:04 BST 2019


Please keep the bug mail address in Cc, so that our findings is

I'll have a look at your details (thanks!) later, there is just one
quick question:

charles xavier, le mer. 28 août 2019 07:55:59 +0200, a ecrit:
> >> Other GTK apps (e.g. gimp, ristretto, xournal) report a different message that may be related:
> >> Gtk-Message: 12:34:56.789: Failed to load module "atk-bridge"
> >
> >That one is easy: that is because libatk-adaptor is not installed.
> Ah, thanks. I installed that. It seems to have worked, getting rid of the "failed to load..." messages. Now that list of apps each gives the same error as the other ones.
> There's probably a better way to find reverse depends, recommends, and suggests, but I did this:
> apt show \* | awk 'BEGIN {p=""} /^$/ {p=""} /^Package: / {p=$2} /^(Recommends|Suggests|Depends): .*\y(libatk-adaptor|at-spi)\y/ {print p; print $0}'
> That earned me a list of four packages that depend on libatk-adaptor: python3-pyatspi, dasher, python-pyatspi, gnome-core. None of them are installed, so I never got libatk-adaptor. Is there a missing dependency that got me to that previous error?

I actually wonder what prompts gtk to try and load atk-bridge. From your
troubleshoot run, it seems you have atk-bridge in


But I wonder where it is coming from. AFAIK it's only requested from
/etc/environment.d/90atk-adaptor.conf and
/etc/X11/Xsession.d/90atk-adaptor, which come from libatk-adaptor

Could you find out (probably in /etc) where this is coming from?

> Still, if the system's state is of interest, I'd be glad to provide output.

Yes it is :)


More information about the Pkg-a11y-devel mailing list