Bug#911362: few packages report not able to register with accessibility bus

charles xavier xavierISdUM4kHmRByIvXeDlpftXZ3 at null.net
Fri Aug 30 19:55:30 BST 2019

> Please keep the bug mail address in Cc, so that our findings is
> recorded.
Ok, did that.

>> Still, if the system's state is of interest, I'd be glad to provide output.
>Yes it is :)
Sure thing. Here we go...

>charles xavier, le mer. 28 août 2019 07:55:59 +0200, a ecrit:
>> >> Other GTK apps (e.g. gimp, ristretto, xournal) report a different message that may be related:
>> >> Gtk-Message: 12:34:56.789: Failed to load module "atk-bridge"
>> >
>> >That one is easy: that is because libatk-adaptor is not installed.
>> Ah, thanks. I installed that. It seems to have worked, getting rid of the "failed to load..." messages. Now that list of apps each gives the same error as the other ones.
>> There's probably a better way to find reverse depends, recommends, and suggests, but I did this:
>> apt show \* | awk 'BEGIN {p=""} /^$/ {p=""} /^Package: / {p=$2} /^(Recommends|Suggests|Depends): .*\y(libatk-adaptor|at-spi)\y/ {print p; print $0}'
>> That earned me a list of four packages that depend on libatk-adaptor: python3-pyatspi, dasher, python-pyatspi, gnome-core. None of them are installed, so I never got libatk-adaptor. Is there a missing dependency that got me to that previous error?
>I actually wonder what prompts gtk to try and load atk-bridge. From your
>troubleshoot run, it seems you have atk-bridge in
>But I wonder where it is coming from. AFAIK it's only requested from
>/etc/environment.d/90atk-adaptor.conf and
>/etc/X11/Xsession.d/90atk-adaptor, which come from libatk-adaptor
>Could you find out (probably in /etc) where this is coming from?

Both of the files you mentioned are on my system, and would seem to set atk-bridge into GTK_MODULES. They're both owned by libatk-adaptor.

In $HOME/.xsession-errors, I see:
dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge

That all seems in order, since libatk-adaptor is now installed. The question might be what was setting it, before libatk-adaptor. My .xsession-errors from then are already overwritten. I did a grep -R libatk-adaptor on /etc and again in relevant $HOME directories, finding nothing but those two config files from libatk-adaptor. Let's see if removing the package does it:
%sudo apt remove --purge libatk-adaptor
%sudo systemctl restart lightdm
%echo Logged back in... > /dev/null
%[ -z "$GTK_MODULES" ] && echo GTK_MODULES is empty.
GTK_MODULES is empty.

Still no errors on starting the binaries that previously had errors.

Looking at /var/log/apt/history.log* I see that libatk-adaptor was installed before the upgrade to buster. It was autoremoved along with its dependency chain, all of which were marked auto:

gnome-orca (3.30.1-1) -> python3-pyatspi (2.30.0+dfsg-3) -> libatk-adaptor (2.30.0-5)

>From there best I've got is that task-xfce-desktop was and is still installed, and recommends gnome-orca. I guess that when I was setting up stretch, APT::Install-Recommends got me gnome-orca installed as automatic; but the recommended packages weren't included for the upgrade to buster.

More information about the Pkg-a11y-devel mailing list