[Pkg-alsa-devel] building alsa-plugins fails w/ libasound has no external plugin SDK

Darren Hart darren at dvhart.com
Sun Dec 14 17:37:32 UTC 2008

On Sun, Dec 14, 2008 at 9:03 AM, Elimar Riesebieter <riesebie at lxtec.de> wrote:
> * Darren Hart [081214 17:20 +0100]
> [...]

Thanks Elimar,

>> So I guess I have two questions:
>> 1) What determined where the lib32asound...deb package ends up
>> installing the 32 bit libs?  and why would it install the libs in
>> /emul and add the ld.so.conf.d/lib32asound.conf file pointint to
>> lib32/alsa-lib?
> /debian/rules defines: bilibdir = emul/ia32-linux/usr/lib

Hrm... You said earlier that debian doesn't install under
/emul/ia32-linux ... So on your system, these are also installed under
emul/ia32-linux/usr/lib ?  Ah, so this only happens for Debian
unstable according to the comment.  I've modified
alsa-lib/debian/rules as follows:

    bilibdir = usr/lib32
    #ifeq ($(DEB_HOST_ARCH),amd64)
      # amd64 unstable only!
      #bilibdir = emul/ia32-linux/usr/lib

After rebuilding alsa-lib, the 32bit libasound.* libs are now
installed in /usr/lib32 along with the other Ubuntu 32bit libs.
Thanks for the pointer.

>> 2) What do I need to do to get the alsa-plugins package to look for
>> the 32bit libs other than updating the ld cache as I've done above?
>> (I did delete the build dir and recreated it with  dpkg-source)
> If your machine is a [amd64 ppc64] lib32asound2-dev is needed for
> build. Check debian/control file for more infos.

I am on an amd64, and I confirmed that lib32asound2-dev is indeed
installed, providing:


And with the change to debian/rules above in the alsa-libs package,
alsa-plugins has now successfully built.  It fails to install however,
complaining about overwriting libraries:

$ sudo dpkg -i *deb
Selecting previously deselected package lib32asound2-plugins.
(Reading database ... 141089 files and directories currently installed.)
Unpacking lib32asound2-plugins (from
lib32asound2-plugins_1.0.18-1_amd64.deb) ...
dpkg: error processing lib32asound2-plugins_1.0.18-1_amd64.deb (--install):
 trying to overwrite
`/usr/lib32/alsa-lib/libasound_module_pcm_pulse.la', which is also in
package ia32-libs

But this appears to be an ubuntu packaging issue.  I'll just overwrite
for now and take it up with the ubuntu folks.

It still doesn't detect my sound cards, while the stock 1.0.17 does...
but that is another thread... :-)

So, is there anything wrong with debian/rules in alsa-libs?  Or is
what I run into just an artifact of trying to build the experimental
debian packages on Ubuntu?  It does seem odd (to me) that alsa-libs
has a special case using /emul for the bilibdir, while alsa-plugins
does not...

Thanks for the help Elimar, much appreciated.

Darren Hart

More information about the Pkg-alsa-devel mailing list