[Pkg-alsa-devel] Bug#635694: alsa-base: alsa bug 0005418: snd-hda-intel: alsa force-reload required to avoid Dummy output

r.ductor at gmail.com r.ductor at gmail.com
Fri Jul 29 07:48:53 UTC 2011


Pulseaudio has been installed automatically by wheezy. I definitely do not need pulseaudio: 5 days ago I did not even know this package.

I tried the following tests.

TEST 1: Created a basic /etc/asound.conf (the file did not exist)

pcm.pulse {
    type pulse
ctl.pulse {
    type pulse
pcm.!default {
    type pulse
ctl.!default {
    type pulse

rebooted: no sound (Dummy device)

TEST2: Installed pavucontrol.
No sound, only Dummy device is seen (see figure).

TEST3: I tried to stop/remove pulseaudio but I failed: it always was there:
* Tried to pulseaudio --kill with both user and root and pulseaudio still there
* Tried update-rc.d pulseaudio disable and reboot  and pulseaudio still there
* Tried update-rc.d -f pulseaudio remove and reboot  and pulseaudio still there
I'm reticent to uninstall an automatically installed package... should I do that?

So all in all I cannot conclude that the problem comes from pulseaudio.
Actually if this was the case, why alsa force-reload gives me back the sound and the Internal Analog Audio Stereo?

Thanks for your help.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: bug_pavucontrol.png
Type: image/png
Size: 21345 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/pkg-alsa-devel/attachments/20110729/d284906a/attachment-0001.png>

More information about the Pkg-alsa-devel mailing list