[Pkg-alsa-devel] Bug#635694: alsa-base: alsa bug 0005418: snd-hda-intel: alsa force-reload required to avoid Dummy output

Elimar Riesebieter riesebie at lxtec.de
Fri Jul 29 16:41:30 UTC 2011

* r.ductor at gmail.com [110729 09:48 +0200]:

> Hello, 
> Pulseaudio has been installed automatically by wheezy. I
> definitely do not need pulseaudio: 5 days ago I did not even know
> this package.
> I tried the following tests.
> TEST 1: Created a basic /etc/asound.conf (the file did not exist)

Tha doesn't make sense at the moment

> rebooted: no sound (Dummy device)
> TEST2: Installed pavucontrol.
> No sound, only Dummy device is seen (see figure).

Did you tried the "Configuration" tab?

> TEST3: I tried to stop/remove pulseaudio but I failed: it always
> was there:
> * Tried to pulseaudio --kill with both user and root
> and pulseaudio still there
> * Tried update-rc.d pulseaudio disable and reboot and pulseaudio 
> still there
> * Tried update-rc.d -f pulseaudio remove and reboot and
> pulseaudio still there 
> I'm reticent to uninstall an automatically installed package...
> should I do that?

What tells:
$ dpkg -l | grep pulse

> So all in all I cannot conclude that the problem comes from
> pulseaudio.  Actually if this was the case, why alsa force-reload
> gives me back the sound and the Internal Analog Audio Stereo?

alsa force-reload steals the driver from pulse and provides them for

  We all know Linux is great... it does infinite loops in 5 seconds.
        -- Linus Torvalds

More information about the Pkg-alsa-devel mailing list