Bug#360143: acknowledged by developer (Bug#360143: fixed in boinc 5.4.3-1)

Frank S. Thomas frank at thomas-alfeld.de
Sat Apr 22 10:09:59 UTC 2006

reopen 360143
tags 360143 = confirmed

On Saturday 22 April 2006 11:28, Zlatko Calusic wrote:
> "Frank S. Thomas" <frank at thomas-alfeld.de> writes:
> > Hi,
> >
> > On Friday 21 April 2006 12:11, Zlatko Calusic wrote:
> >> Unfortunately, the situation is even worse, now I can't connect at all
> >> (not even after a minute or so). It all seems pretty bugged. Whatever
> >> I click (retry communications, select computer...) I don't get an
> >> expected response but only blocking, "nothing happens" and other
> >> (circular) errors. Weird.
> >
> > Which version is the BOINC core client you are trying to connect to? I
> > assume it is not 5.4.3. Can you upgrade the client to this version?
> Yes, they're both 5.4.3. I doublechecked and restarted client on the
> other machine to be sure the new version is running. Still no go.
> To help a little bit let go step by step and see what's happening:
> - boinc-client 5.4.3-1 is running at machine.domain.com
> - port 31416 is open by boinc-client process and I can connect with
>   telnet to it and get some xml errors out from desktop.domain.com
> - I fire up boincmgr 5.4.3-1 on the desktop.domain.com (I don't have
>   boinc-client installed on that machine!)
> - In the tray? (down on the right of the window) it says 'Connecting
>   to localhost' and on the console it says:
>   send: -1
>   send: Bad file descriptor
>   connect: Connection refused
>   execvp(./boinc, -redirectio) failed with error 2!
>   connect: Operation now in progress
> - I go to Advanced->Select Computer and select machine.desktop.com
>   from the drop down history, tray immediately changes to 'Connecting
>   to machine.domain.com' but nothing happens...
> - NEW DATA: I wait exactly 50 seconds starring at the screen where
>   nothing happens and finally get a popup saying that Connection
>   failed and giving me a chance to retry, I salect 'Yes'
> - In the next second, I'm finally connected properly!
> So yes, the original bug that I reported is still there in 5.4.3-1, I
> still have to wait around a minute to get connected properly to a
> remote machine.

I've just checked again and I can confirm your report and therefore reopen 
this bug. I could have sworn that it was fixed with the new release. The 
patch I sent upstream fixed it, but they only applied one part of the patch, 
which is apparently not enough.

Thanks again,

Anmut bringen wir ins Leben;
 Leget Anmut in das Geben.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.alioth.debian.org/pipermail/pkg-boinc-devel/attachments/20060422/e531d4a8/attachment.pgp

More information about the pkg-boinc-devel mailing list