[Pkg-crosswire-devel] package upload sponsorship requests [WAS: Re: SWORD 1.5.11-1 now really in Debian experimental -- time for a second Bibletime upload attempt?]

Roberto C. Sánchez roberto at connexer.com
Fri Apr 17 15:27:12 BST 2009

On Thu, Apr 16, 2009 at 11:34:04PM -0700, Jonathan Marsden wrote:
> Roberto C. Sánchez wrote:
> >>   http://computeroptions.net/sword/bibletime_2.0~alpha3-1.dsc
> > Hmm ... in my pbuilder chroot (which has the libsword-dev from
> > experimental in it) fails like this: ...
> I have no idea what causes that, unless we have a missing build
> dependency somehow?  libsword7?  What else might it be?  I just can't
> duplicate the issue here (so far).  If you can suggest things I can do
> to duplicate this issue, that would be helpful.
> As a simple test, I just rebuilt that bibletime package in Debian Lenny
> with libsword-dev and libsword7 installed, (not in a pbuilder, see
> below) by being fairly boring, doing:
>   mkdir test
>   cd test
>   dget -x http://computeroptions.net/sword/bibletime_2.0~alpha3-1.dsc
>   dpkg-source -x *.dsc
>   cd bibletime-2.0~alpha3
>   debuild
>   debuild -S -sa
> and it "just works".  I then repeated this in my sid VM, with the exact
> same result -- it works there too, at least for me!
You really need to be building in a clean sid chroot.

> I cannot get pbuilder to create me a sid or experimental pbuilder at
> all, which is rather frustrating!  Apparently, sid is self-inconsistent
> regarding some packages at the moment, and the "answer" is (I am told)
> to wait for a few days and try again :-/
> The error I am seeing (after a long delay while everything is downloaded
> and installed!) is:
>  The following packages have unmet dependencies:
>    aptitude: Depends: libapt-pkg-libc6.7-6-4.6 but it is not installable
>              Depends: libept0 (>= 0.5.22) but it is not going to be
> installed
>  E: Broken packages
>   -> Aborting with an error
> If there is something I can do to work around this and create a usable
> sid pbuilder, please let me know.
I saw that too last night, but when upgrading on i386.  So you have an
amd64 machine handy that you can try it out on?

> [Aside: This is the kind of thing that makes me want to retreat to the
> safety and comfort of Ubuntu -- I had a Jaunty pbuilder months ago when
> it was still alpha1 or even before that, and it built fine and "worked"
> to the extent that Jaunty itself was "working" at that stage.  I can
> understand people uploading stuff to experimental that breaks something
> this way... but to unstable?  I suppose it really *is* "unstable"! ]
Well, unstable is as it says ... unstable.  Library transitions, in
particular, are nearly always handled in unstable.  Those can
occasionally take a day or two to settle down.  Ubuntu is not immune to
this either.

> I hope to have some more time to chase this down Friday evening and
> Saturday.  Maybe someone will have fixed sid by then so pbuilder create
> will work?
OK.  Whenever someone figures out the error and fixes the package I will
upload it.  Unfortunately, I do not have time to try and solve the

Incidentally, *before* requesting sponsorship for upload, please do the

 1. build in a *clean* sid chroot
 2. run the resultant source and binary packages through lintian (from
    sid) like so: 'lintian -viI <package>.changes' (make sure it is the 
    .changes file)
 3. run it through piuparts

Taking these three simple steps will save everyone involved lots of



Roberto C. Sánchez
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
URL: <http://alioth-lists.debian.net/pipermail/pkg-crosswire-devel/attachments/20090417/969fb593/attachment.sig>

More information about the Pkg-crosswire-devel mailing list