[Pkg-cryptsetup-devel] Bug#465812: Bug#465812: linux-image-2.6.22-3-686: [Regression] LuKS passphrase not accepted anymore

Jonas Meurer jonas at freesources.org
Fri Feb 15 21:16:06 UTC 2008

On 15/02/2008 Martin Ammermüller wrote:
> On Friday 15 February 2008 17:23:39 maximilian attems wrote:
> > On Fri, 15 Feb 2008, Martin Ammermüller wrote:
> > > Tried that for 2.6.22-3-686 and 2.6.24 with no effect. And I'm pretty
> > > sure that i didn't enter the passphrase wrong :) (works still with
> > > 2.6.22-2, did not try my luck with update-initramfs on this kernel-image,
> > > though).
> >
> > well then it can only be a cryptetup bug of newer version.
> > as newer cryptsetup land on both of those.
> Looks like the keyboard-layout isn't set up correctly. I run etch installer 
> with german keyboard layout. If I enter the passphrase like my keyboard had 
> an english layout, it works with linux-image 2.6.24. I also did a diff of 
> initrd.img from 2.6.22-2 and 2.6.22-3. /bin/kbd_mode as well as /bin/loadkeys 
> are missing in initrd.img-2.6.22-3:

David, can you take a look at this one? What exactly is responsible for
putting kbd_mode and loadkeys into the initramfs? A brief search through
the cryptsetup initramfs scripts/hooks gave no result, so I doubt that
that's the source for the problem. But you should know more ;-)


More information about the Pkg-cryptsetup-devel mailing list