[Pkg-cryptsetup-devel] Bug#465812: Bug#465812: linux-image-2.6.22-3-686: [Regression] LuKS passphrase not accepted anymore

Jonas Meurer jonas at freesources.org
Sat Feb 16 17:51:37 UTC 2008

On 15/02/2008 Martin Ammermüller wrote:
> On Friday 15 February 2008 17:23:39 maximilian attems wrote:
> > On Fri, 15 Feb 2008, Martin Ammermüller wrote:
> > > Tried that for 2.6.22-3-686 and 2.6.24 with no effect. And I'm pretty
> > > sure that i didn't enter the passphrase wrong :) (works still with
> > > 2.6.22-2, did not try my luck with update-initramfs on this kernel-image,
> > > though).
> >
> > well then it can only be a cryptetup bug of newer version.
> > as newer cryptsetup land on both of those.
> Looks like the keyboard-layout isn't set up correctly. I run etch installer 
> with german keyboard layout. If I enter the passphrase like my keyboard had 
> an english layout, it works with linux-image 2.6.24. I also did a diff of 
> initrd.img from 2.6.22-2 and 2.6.22-3. /bin/kbd_mode as well as /bin/loadkeys 
> are missing in initrd.img-2.6.22-3:

And Martin, could you try to update your initramfs for the older kernels
as well? Did you update cryptsetup in the last days/shortly before the
issues occured?

Please backup your initrd files, and recreate them afterwards
(update-initramfs -k all -u).

Afterwards please test whether your old kernel (2.6.22-2) still doesn't
have the described problem.

To be honest, I've no idea where to locate the bug right now. Afair
nothing specific to initramfs changed in the cryptsetup package lately.

Maks, don't you think that this bug might be caused by recent changes in
kernel and/or initramfs-tools?


More information about the Pkg-cryptsetup-devel mailing list