[Pkg-fonts-devel] BD:fontforge rebuild

Vasudev Kamath vasudev at copyninja.info
Sat Jul 2 13:12:47 UTC 2016

Adam Borowski <kilobyte at angband.pl> writes:

> On Mon, Jun 27, 2016 at 07:30:07AM +0200, Adam Borowski wrote:
>> I've done another rebuild on anything that [transitively] build-depends on a
>> binary produced by src:fontforge.
> Oif, I've managed to screw up the list of packages to rebuild.  I've missed
> some new fails.

No issue :-).

>> Still unrelated: lilypond.
> Really: lilypond, wine.

Hmm, I've not tried building it yet. First I will try to fix the related builds.
>> Still FTBFSes: fonts-okolaks, fonts-pecita, mtrace, ttf-goudybookletter.
>> New failures:
>> * fonts-lohit-gujr
>> * latex-cjk-chinese-arphic
>> * wine-development
> fonts-okolaks, fonts-pecita, mtrace, ttf-goudybookletter,
> wine-development.

I tried fonts-pecita and it looks like it fails in Validation step of
compile.pe not sure if its issue of fontforge or something else. I did a
quick manual compilation with latest fontforge and so it print
validation error. If it passes validation it creates the otf file.

> Ones I missed:
> * mensis
> checking fontforge/basics.h usability... no
> checking fontforge/basics.h presence... no
> checking for fontforge/basics.h... no
> You must install the include files for fontforge
> before building mensis.
> debian/rules:29: recipe for target 'override_dh_auto_configure' failed

Is this really related to fontforge?. I checked basics.h is part of
libfontforge-dev. Is this missing dependency?. See the built package
output from dpkg -c.

-rw-r--r-- root/root     26938 2016-07-02 15:09 ./usr/include/fontforge/baseviews.h
-rw-r--r-- root/root      3909 2016-07-02 15:09 ./usr/include/fontforge/basics.h
-rw-r--r-- root/root       160 2016-07-02 15:09 ./usr/include/fontforge/bezctx_ff.h

> * pdf2htmlex
> /usr/bin/cc   -I/<<BUILDDIR>>/pdf2htmlex-0.14.6+ds/src -I/usr/include/poppler -I/usr/include/fontforge
> -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2  -Wall
> -o CMakeFiles/pdf2htmlEX.dir/src/util/ffw.c.o   -c /<<BUILDDIR>>/pdf2htmlex-0.14.6+ds/src/util/ffw.c
> In file included from /usr/include/fontforge/baseviews.h:30:0,
>                  from /<<BUILDDIR>>/pdf2htmlex-0.14.6+ds/src/util/ffw.c:17:
> /usr/include/fontforge/ffglib.h:27:18: fatal error: glib.h: No such file or directory
> compilation terminated.
> CMakeFiles/pdf2htmlEX.dir/build.make:425: recipe for target 'CMakeFiles/pdf2htmlEX.dir/src/util/ffw.c.o' failed

OK this is now fixed in git basically I had to add all -dev libraries of
libraries which are build-depends of fontforge. I did better by using
d-shlibs where it automatically calculates required dependencies. The
change is in git. Can you try again?.

More information about the Pkg-fonts-devel mailing list