[Pkg-fonts-devel] BD:fontforge rebuild

Adam Borowski kilobyte at angband.pl
Sat Jul 2 17:43:37 UTC 2016

On Sat, Jul 02, 2016 at 06:42:47PM +0530, Vasudev Kamath wrote:
> Adam Borowski <kilobyte at angband.pl> writes:
> > On Mon, Jun 27, 2016 at 07:30:07AM +0200, Adam Borowski wrote:
> >> Still unrelated: lilypond.
> > Really: lilypond, wine.
> Hmm, I've not tried building it yet. First I will try to fix the related builds.

Both are unbuildable: lilypond needs to be ported to newer guile, wine needs
to cope with new unicode-data -- ie, not our direct concern.

> I tried fonts-pecita and it looks like it fails in Validation step of
> compile.pe not sure if its issue of fontforge or something else. I did a
> quick manual compilation with latest fontforge and so it print
> validation error. If it passes validation it creates the otf file.

It's a problem known to upstreams of both pecita and fontforge:

> > checking fontforge/basics.h usability... no
> > checking fontforge/basics.h presence... no
> > checking for fontforge/basics.h... no
> > You must install the include files for fontforge
> > before building mensis.
> > debian/rules:29: recipe for target 'override_dh_auto_configure' failed
> Is this really related to fontforge?. I checked basics.h is part of
> libfontforge-dev. Is this missing dependency?. See the built package
> output from dpkg -c.
> -rw-r--r-- root/root     26938 2016-07-02 15:09 ./usr/include/fontforge/baseviews.h
> -rw-r--r-- root/root      3909 2016-07-02 15:09 ./usr/include/fontforge/basics.h
> -rw-r--r-- root/root       160 2016-07-02 15:09 ./usr/include/fontforge/bezctx_ff.h

New /usr/include/fontforge/basics.h has:
#include <fontforge-config.h>
yet during that check that file is not in the include path.  There are two
ways to find it: either #include <fontforge/fontforge-config.h> or add
/usr/include/fontforge to -I.

Mensis does call configure --includedir=/usr/include/fontforge yet the
actual check does:
configure:12535: gcc -c -g -O2 -fPIE -fstack-protector-strong -Wformat
    -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2
    -I/usr/include/freetype2/ conftest.c >&5

This looks like a bug in mensis rather than fontforge to me, but we can fix
it in either.

> > * pdf2htmlex
> >
> > /usr/bin/cc   -I/<<BUILDDIR>>/pdf2htmlex-0.14.6+ds/src -I/usr/include/poppler -I/usr/include/fontforge
> > -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2  -Wall
> > -o CMakeFiles/pdf2htmlEX.dir/src/util/ffw.c.o   -c /<<BUILDDIR>>/pdf2htmlex-0.14.6+ds/src/util/ffw.c
> > In file included from /usr/include/fontforge/baseviews.h:30:0,
> >                  from /<<BUILDDIR>>/pdf2htmlex-0.14.6+ds/src/util/ffw.c:17:
> > /usr/include/fontforge/ffglib.h:27:18: fatal error: glib.h: No such file or directory
> > compilation terminated.
> > CMakeFiles/pdf2htmlEX.dir/build.make:425: recipe for target 'CMakeFiles/pdf2htmlEX.dir/src/util/ffw.c.o' failed
> OK this is now fixed in git basically I had to add all -dev libraries of
> libraries which are build-depends of fontforge. I did better by using
> d-shlibs where it automatically calculates required dependencies.

Still fails with the same error.

> The change is in git.  Can you try again?.

Sure, just did another rebuild:

Still unrelated: lilypond, wine.
Still FTBFS: fonts-okolaks, fonts-pecita, mensis, mftrace, pdfhtmlex,
    ttf-goudybookletter, wine-development.
Fixed: fonts-lohit-gujr, latex-cjk-chinese-arphic.

An imaginary friend squared is a real enemy.

More information about the Pkg-fonts-devel mailing list