Bug#271765: marked as done (gnome crashes - hardware freeze)

Debian Bug Tracking System owner@bugs.debian.org
Sun, 26 Sep 2004 15:18:06 -0700

Your message dated Sun, 26 Sep 2004 23:52:01 +0200
with message-id <20040926215200.GA2587@nubol.int.oskuro.net>
and subject line No feedback, completely unreproducible
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 15 Sep 2004 05:12:51 +0000
>From jdh@hend.net Tue Sep 14 22:12:51 2004
Return-path: <jdh@hend.net>
Received: from lakermmtao04.cox.net [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1C7S67-0000YB-00; Tue, 14 Sep 2004 22:12:51 -0700
Received: from hend.net ([]) by lakermmtao04.cox.net
          (InterMail vM. 201-2131-111-104-103-20040709)
          with ESMTP
          id <20040915051218.UWUB11880.lakermmtao04.cox.net@hend.net>
          for <submit@bugs.debian.org>; Wed, 15 Sep 2004 01:12:18 -0400
Received: (from jdh@localhost)
	by hend.net (8.12.9/8.12.9/Submit) id i8F5CJNl003610;
	Wed, 15 Sep 2004 01:12:19 -0400
Message-Id: <200409150512.i8F5CJNl003610@hend.net>
From: "John D. Hendrickson" <jdh@hend.net>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: gnome crashes - hardware freeze
X-Mailer: reportbug 1.50
Date: Wed, 15 Sep 2004 01:12:19 -0400
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Package: gnome
Version: N/A; reported 2004-09-15
Severity: normal

-- System Information
Debian Release: 3.0
Architecture: i386
Kernel: Linux link 2.4.20-mm #1 Tue Feb 24 17:47:00 EST 2004 i586

# for the systems I'm refering to

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
    APT policy: (500, 'testing')
    Architecture: i386 (i686)
    Kernel: Linux 2.6.7-k7
    Locale: LANG=C, LC_CTYPE=C (ignored: LC_ALL set to C)


On 3 out of 3 machines gnome is severely unstable and incompletely installed.

	--> missing icons (ie, "Home" appears as blank sheet not a house)
	gdm crashes (and freezes computer hard with it)
	xterm and other things have many font problems and eel problems.
	gnome terminal doesn't work
	--> abiword often crashes with "Fatal: can't allocate memory"
		(reproducible, easily: just open print preview)

All had woody (separately installed - one a fresh install).  All were
dist-upraded to sarge individually.

* KDE works fine on all machines.
* All old gnome files were removed from user dirs in effort to locate problem.
* I tried installed as many gnome packages (for sarge) as seemed sane.
* I tried reinstalling base gnome packages.

Sorry I can't be drop dead specific as to why.  I beleive it to be both
improper compiling and improper distribution.

Why?  I dl'ed Gnome 2.6.1 myself and compiled it and it has none of the
problem (save I skipped compiling epiphany and gnomemeeting).
	1) I have icons installed
	2) abiword doesn't crash
	3) gnome terminal works great
	4) noticeable speed increase in trying themes and in other areas

	(I use my own xmd - haven't tried gdm in a while ;)

Now I did the compile sloppily - not insurning any of my compiling machine's
libraries / headers weren't wrong.  (so if I can do it like an idiot and
have not problems...)

So, I guess what I'm saying is: I really wish someone over there would redo
all of sarge's packages of gnome and have it checked and re-checked for
install / uninstall / upgrade (all of, in any order) by a typical user.  I
do think someone did it wrong - for whatever reasons.


    John D. Hendrickson



Received: (at 271765-done) by bugs.debian.org; 26 Sep 2004 22:04:03 +0000
>From jordi@debian.org Sun Sep 26 15:04:03 2004
Return-path: <jordi@debian.org>
Received: from 115.red-213-96-69.pooles.rima-tde.net (natura.oskuro.net) [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1CBh7g-0003eg-00; Sun, 26 Sep 2004 15:04:03 -0700
Received: from nubol.int.oskuro.net (nubol.int.oskuro.net [])
	by natura.oskuro.net (Postfix) with ESMTP id 0DD55277B7
	for <271765-done@bugs.debian.org>; Mon, 27 Sep 2004 00:03:24 +0200 (CEST)
Received: by nubol.int.oskuro.net (Postfix, from userid 1000)
	id 1C69670A746; Sun, 26 Sep 2004 23:52:01 +0200 (CEST)
Date: Sun, 26 Sep 2004 23:52:01 +0200
From: Jordi Mallach <jordi@debian.org>
To: 271765-done@bugs.debian.org
Subject: No feedback, completely unreproducible
Message-ID: <20040926215200.GA2587@nubol.int.oskuro.net>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="dDRMvlgZJXvWKvBx"
Content-Disposition: inline
User-Agent: Mutt/1.5.6+20040818i
Delivered-To: 271765-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-3.0 required=4.0 tests=BAYES_00 autolearn=no 

Content-Type: text/plain; charset=iso-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable


I'm closing this bug given it's extremely likely the problem is
something strange going on in your install, not Debian related.

If you disagree with this please reply to this bug giving us the details
we asked for.

Jordi Mallach P=E9rez  --  Debian developer     http://www.debian.org/
jordi@sindominio.net     jordi@debian.org     http://www.sindominio.net/
GnuPG public key information available at http://oskuro.net/~jordi/

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.2.5 (GNU/Linux)