Bug#900819: gimp: Dependency on liblcms2-2 needs tightening

Michael Deegan bugs at deegan.id.au
Sat Apr 3 10:06:49 BST 2021

Package: gimp
Version: 2.10.22-3
Followup-For: Bug #900819

Hello, I can confirm that the issue still exists (being part way through
gradually upgrading my machine from buster to bullseye).

However, it's more confusing now! The message from Gimp:

    Liblcms2 version mismatch!

    GIMP was compiled against LittleCMS version 2.2, but the
    LittleCMS version found at runtime is only 2.9.

    Somehow you or your software packager managed
    to install a LittleCMS that is older than what GIMP was
    built against.

    Please make sure that the installed LittleCMS version
    is at least 2.2 and that headers and library match.

By my understanding, 2.9 *is* a version number later than 2.2. :P

My uneducated guess is that something plucked "2.2" from somewhere, where
there should have been a *checks apt-cache policy* "2.12".

-- System Information:
Debian Release: 10.9
  APT prefers testing-debug
  APT policy: (500, 'testing-debug'), (500, 'stable-updates'), (500, 'stable-debug'), (500, 'proposed-updates-debug'), (500, 'oldstable-updates'), (500, 'stable'), (500, 'oldstable'), (480, 'testing'), (470, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.10.0-5-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_AU.utf8, LC_CTYPE=en_AU.utf8 (charmap=UTF-8), LANGUAGE=en_AU:en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages gimp depends on:
ii  gimp-data            2.10.22-3
ii  graphviz             2.40.1-6
ii  libaa1               1.4p5-46
ii  libbabl-0.1-0        1:0.1.82-1
ii  libbz2-1.0           1.0.6-9.2~deb10u1
ii  libc6                2.31-10
ii  libcairo2            1.16.0-4+deb10u1
ii  libfontconfig1       2.13.1-2
ii  libfreetype6         2.10.4+dfsg-1
ii  libgcc-s1            10.2.1-6
ii  libgdk-pixbuf-2.0-0  2.42.2+dfsg-1
ii  libgegl-0.4-0        1:0.4.26-2
ii  libgexiv2-2          0.10.9-1
ii  libgimp2.0           2.10.22-3
ii  libglib2.0-0         2.66.8-1
ii  libgs9               9.27~dfsg-2+deb10u4
ii  libgtk2.0-0          2.24.32-3
ii  libgudev-1.0-0       232-2
ii  libharfbuzz0b        2.3.1-1
ii  libheif1             1.11.0-1
ii  libilmbase25         2.5.4-1
ii  libjpeg62-turbo      1:1.5.2-2+deb10u1
ii  libjson-glib-1.0-0   1.6.2-1
ii  liblcms2-2           2.9-3
ii  liblzma5             5.2.4-1
ii  libmng1              1.0.10+dfsg-3.1+b5
ii  libmypaint-1.5-1     1.6.0-2
ii  libopenexr25         2.5.4-1
ii  libopenjp2-7         2.3.0-2+deb10u2
ii  libpango-1.0-0       1.42.4-8~deb10u1
ii  libpangocairo-1.0-0  1.42.4-8~deb10u1
ii  libpangoft2-1.0-0    1.42.4-8~deb10u1
ii  libpng16-16          1.6.36-6
ii  libpoppler-glib8     20.09.0-3.1
ii  librsvg2-2           2.44.10-2.1
ii  libstdc++6           10.2.1-6
ii  libtiff5             4.1.0+git191117-2~deb10u2
ii  libwebp6             0.6.1-2
ii  libwebpdemux2        0.6.1-2
ii  libwebpmux3          0.6.1-2+b1
ii  libwmf0.2-7
ii  libx11-6             2:1.7.0-2
ii  libxcursor1          1:1.1.15-2
ii  libxext6             2:1.3.3-1.1
ii  libxfixes3           1:5.0.3-1
ii  libxmu6              2:1.1.2-2+b3
ii  libxpm4              1:3.5.12-1
ii  xdg-utils            1.1.3-1+deb10u1
ii  zlib1g               1:1.2.11.dfsg-1

Versions of packages gimp recommends:
ii  ghostscript  9.27~dfsg-2+deb10u4

Versions of packages gimp suggests:
ii  gimp-data-extras          1:2.0.2-1
ii  gimp-help-en [gimp-help]  2.8.2-1
ii  gvfs-backends             1.38.1-5
ii  libasound2                1.1.8-1

-- no debconf information

More information about the pkg-gnome-maintainers mailing list