Bug#900819: gimp: Dependency on liblcms2-2 needs tightening

Simon McVittie smcv at debian.org
Sat Apr 3 11:11:37 BST 2021

On Sat, 03 Apr 2021 at 17:06:49 +0800, Michael Deegan wrote:
> Hello, I can confirm that the issue still exists (being part way through
> gradually upgrading my machine from buster to bullseye).

I would recommend trying to do the majority of the buster -> bullseye
upgrade in one go.

If you upgrade individual packages from buster to bullseye, that is
something that is *meant* to work, but realistically, there will be a bug
somewhere: there's an extremely large number of possible partial upgrades,
and Debian maintainers cannot test more than a tiny fraction of them. The
combination of packages on your system during a partial upgrade is likely
to be something unique to your system that nobody else has ever tested.

>     Liblcms2 version mismatch!
>     GIMP was compiled against LittleCMS version 2.2, but the
>     LittleCMS version found at runtime is only 2.9.
> My uneducated guess is that something plucked "2.2" from somewhere, where
> there should have been a *checks apt-cache policy* "2.12".

Looks like GIMP is parsing the LCMS_VERSION incorrectly when generating
this error message, based on an assumption that the minor version is a
single decimal digit: it says 2.2, but it really means 2.12. The version
number that it is actually comparing before generating the error message
is 209x < 2120 (meaning 2.9.x < 2.12.0), which makes more sense.

The gimp packaging should either generate tighter dependencies at
compile-time, or patch out these checks as redundant with the dependency


More information about the pkg-gnome-maintainers mailing list