Bug#514578: libgnutls26: similar gnutls26 problem with mutt+msmtp after recent update

Chess Griffin chess at chessgriffin.com
Tue Feb 10 16:29:15 UTC 2009

* Simon Josefsson <simon at josefsson.org> [2009-02-10 17:16:33]:

> Chess Griffin <chess at chessgriffin.com> writes:
> > Package: libgnutls26
> > Followup-For: Bug #514578
> >
> > I have a similar issue with the recent update.  Mutt and msmtp have been
> > working fine for years with my email provider, Tuffmail.  I use SSL/TLS
> > for IMAP and SMTP.
> >
> > After the recent libgnutls26 update, I could not log in to IMAP using
> > SSL -- Mutt would complain it could not save the certificate in my
> > ~/.mutt/mutt-certs even thought the proper cert was already there.
> > Then, when sending, msmtp complained that the cert was invalid.  Again,
> > everything was working fine, my configs had not changed, and my provider
> > had not changed their certs.
> >
> > I downgraded to libgnutls26 2.4.2-4 and now everything works again.
> Please upgrade to 2.4.2-6 and see if the problem has been fixed.
> /Simon

I had tried that previously and it did not work.  After getting your
email, I tried it again and it still does not work.  This is what

When I log in to mutt, it tries to save the cert (even though cert is
already in my ~/.mutt/mutt-certs file) and it says it cannot save the
cert.  Then, when sending in mutt (via msmtp), msmtp complains that cert
is not valid and will not send.

If I downgrade back to 2.4.2.-4, everything works again.

Chess Griffin
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
Url : http://lists.alioth.debian.org/pipermail/pkg-gnutls-maint/attachments/20090210/1afa0397/attachment.pgp 

More information about the Pkg-gnutls-maint mailing list