Bug#514578: libgnutls26: similar gnutls26 problem with mutt+msmtp after recent update

Simon Josefsson simon at josefsson.org
Tue Feb 10 21:09:18 UTC 2009

Chess Griffin <chess at chessgriffin.com> writes:

> * Simon Josefsson <simon at josefsson.org> [2009-02-10 17:16:33]:
>> Chess Griffin <chess at chessgriffin.com> writes:
>> > Package: libgnutls26
>> > Followup-For: Bug #514578
>> >
>> > I have a similar issue with the recent update.  Mutt and msmtp have been
>> > working fine for years with my email provider, Tuffmail.  I use SSL/TLS
>> > for IMAP and SMTP.
>> >
>> > After the recent libgnutls26 update, I could not log in to IMAP using
>> > SSL -- Mutt would complain it could not save the certificate in my
>> > ~/.mutt/mutt-certs even thought the proper cert was already there.
>> > Then, when sending, msmtp complained that the cert was invalid.  Again,
>> > everything was working fine, my configs had not changed, and my provider
>> > had not changed their certs.
>> >
>> > I downgraded to libgnutls26 2.4.2-4 and now everything works again.
>> Please upgrade to 2.4.2-6 and see if the problem has been fixed.
>> /Simon
> I had tried that previously and it did not work.  After getting your
> email, I tried it again and it still does not work.  This is what
> happens:
> When I log in to mutt, it tries to save the cert (even though cert is
> already in my ~/.mutt/mutt-certs file) and it says it cannot save the
> cert.  Then, when sending in mutt (via msmtp), msmtp complains that cert
> is not valid and will not send.
> If I downgrade back to 2.4.2.-4, everything works again.

Can you reproduce the problem using gnutls-cli?  It sounds as if you
have a RSA-MD5 signature somewhere in your chain, and the chain is
rejected.  Please post output of running gnutls-cli against your server
as suggested earlier in this bug.

If you could quote some error messages from mutt and msmtp, that will
also help -- however, to debug it is best to first try to isolate the
problem using gnutls-cli.  If it's not possible to reproduce using
gnutls-cli, I would suggest a mutt/msmtp problem.


More information about the Pkg-gnutls-maint mailing list