[pkg-go] Bug#960022: gitaly fails at installing in postinst

Eric Van Buggenhaut ericvb69 at gmail.com
Fri May 8 13:29:24 BST 2020

Package: gitaly
Version: 1.78.0+dfsg-2
Severity: important

# apt-get install gitaly
Reading package lists... Done
Building dependency tree       
Reading state information... Done
gitaly is already the newest version (1.78.0+dfsg-2).
0 upgraded, 0 newly installed, 0 to remove and 995 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] 
Setting up gitaly (1.78.0+dfsg-2) ...
Could not find gem 'gitlab-labkit (~> 0.5.0)' in any of the gem sources listed in your Gemfile.
dpkg: error processing package gitaly (--configure):
 installed gitaly package post-installation script subprocess returned error exit status 7
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

The error triggers at this point:

root at bragi:/usr/share/gitaly/ruby# runuser -u gitlab -- sh -c "bundle install --local"
Could not find gem 'gitlab-labkit (~> 0.5.0)' in any of the gem sources listed in your Gemfile.

# cat Gemfile
source 'https://rubygems.org'

# Require bundler >= 1.16.5 to avoid this bug: https://github.com/bundler/bundler/issues/6537
gem 'bundler', '>= 1.17.3'

gem 'rugged', '~> 0.28'
gem 'github-linguist', '~> 7.5', require: 'linguist'
gem 'github-markup', '~> 1.7'
gem 'activesupport', '~> 5.2.3'
gem 'rdoc', '~> 6.0'
gem 'gitlab-gollum-lib', '~>', require: false
gem 'gitlab-gollum-rugged_adapter', '~>', require: false
gem 'grpc', '~> 1.16'
gem 'sentry-raven', '~> 2.9', require: false
gem 'faraday', '~> 0.12'
gem 'rbtrace', require: false

# Labkit provides observability functionality
gem 'gitlab-labkit', '~> 0.5.0'

# Detects the open source license the repository includes
# This version needs to be in sync with GitLab CE/EE
gem 'licensee', '~> 8.9'

gem 'google-protobuf', '~> 3.6'

-- System Information:
Debian Release: 10.3
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'buster-fasttrack'), (500, 'unstable'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 5.3.13-1-pve (SMP w/12 CPU cores)
Locale: LANG=C, LC_CTYPE=C.UTF-8 (charmap=UTF-8), LANGUAGE=C (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages gitaly depends on:
ii  gitlab-common               12.2.9-5+fto10+2
ii  libc6                       2.28-10
ii  libgit2-28                  0.28.3+dfsg.1-1~bpo10+1
ii  pipexec                     2.5.5-2
ii  procps                      2:3.3.15-2
ii  ruby                        1:2.5.1
ii  ruby-activesupport          2:5.2.3+dfsg-1~bpo10+1
ii  ruby-faraday                0.13.1-2
ii  ruby-github-linguist        7.7.0-2~bpo10+1
ii  ruby-github-markup          1.7.0+dfsg-2
ii  ruby-gitlab-labkit          0.12.0-2
ii  ruby-gollum-lib   
ii  ruby-gollum-rugged-adapter
ii  ruby-google-protobuf        3.11.4-3~bpo10+1
ii  ruby-grpc                   1.19.1-1~bpo10+1
ii  ruby-licensee               8.9.2-1
ii  ruby-rbtrace                0.4.10-1
ii  ruby-rugged       
ii  ruby-sentry-raven           2.9.0-1~bpo10+1

gitaly recommends no packages.

gitaly suggests no packages.

-- no debconf information

More information about the Pkg-go-maintainers mailing list