Bug#886742: postgresql-9.4-postgis-2.1 missing in stretch

Bas Couwenberg sebastic at xs4all.nl
Tue Jan 9 13:16:49 UTC 2018

On 2018-01-09 14:08, Christoph Berg wrote:
> Re: Juergen Fuchsberger 2018-01-09
> <20180109130149.17725.10545.reportbug at wegc203058.uni-graz.at>
>> Due to missing postgresql-9.4-postgis-2.1 in stretch, a postgis 
>> enabled
>> database becomes corrupt when upgrading from jessie to stretch since
>> the required postgis libraries are missing. This can cause serious 
>> data
>> loss, because once upgraded to stretch, the postgis data can't be
>> accesed nor dumped (Database gives error "could not access file
>> "$libdir/postgis-2.1": no such file or directory").
> Could you append the apt output to this bug? Namely, which packages
> got removed? (/var/log/apt/term.log)
>> Also upgrading the database to postgresql-9.6 does not work.
> What did you try, and what didn't work?

Probably pg_upgradecluster, and that is not supported for databases with 
the postgis extension.

See my reply to #886738 and 

For more info, see:


As long as the postgis package is built for a single postgresql version, 
upgrades cannot be supported.

When using postgis on Debian, distribution upgrades involve recreating 
the postgis databases as pg_upgradecluster will fail.

Kind Regards,


More information about the Pkg-grass-devel mailing list